[shifter-users] Window Switch problem

Antoine Martin antoine at devloop.org.uk
Tue Feb 15 07:36:23 GMT 2011

Can you login via ssh as that user?
Multicast is tricky but you are right: if it has connected before, it 
should be ok.
Try running avahi-discover to browse the services it advertises.

The quick-connect window does use ssh if you select it, which should not 
be necessary since you have disabled the firewalls, but is worth trying 

Note: the server should be running on the system before you attempt to 
connect. If the applet is running, it should have started a server for 
you already (unless you disabled it in the options).

The accounts do not have to be the same, it shouldn't make much 
difference unless you start fiddling the user account multicast filter 
("match username").

If all else fails, you can run the server in debug mode and send me the 
log output (starting when you attempt to connect if possible):
winswitch_server --debug-mode


On 15/02/11 10:19, Jimi Bove wrote:
> I forgot to add, I think it might have something to do with the users. 
> I can't figure out how to create users the computers can log into, but 
> I don't know how they could log in to some random user. I mean it 
> requires a password. How do I set all that stuff? And does the fact 
> that the usernames of the accounts on both computers are the same, as 
> are the usernames connected to their local servers, change anything?
> On Mon, Feb 14, 2011 at 7:17 PM, Jimi Bove <jimijames.bove at gmail.com 
> <mailto:jimijames.bove at gmail.com>> wrote:
>     I'm trying to get my Linux and Windows computers connected with
>     this program and it just refuses to work. When I first tried it, I
>     launched winsitch_applet through the terminal in Linux. The tray
>     icon didn't appear, but the server started and the Windows
>     computer automatically connected. After that incident, the tray
>     icon now appears and both computers see each other, but they can't
>     connect. I've tried every setting with both firewalls disabled,
>     and I don't know what else to try. The fact that it worked once
>     rules out multicast issues, doesn't it?

More information about the shifter-users mailing list