[shifter-users] Window Switch problem

Antoine Martin antoine at nagafix.co.uk
Tue Feb 15 23:41:50 GMT 2011

On 16/02/11 00:08, Jimi Bove wrote:
> I think we have found the problem. avahi-discover can see everything 
> on my network and get the information on it all just fine, including 
> other Linux and Mac stuff. However, anything that comes from my 
> Windows computer is detected, but I can't get any info on it. It just 
> says "Error: org.freedesktop.Avahi.TimeoutError: Timeout reached". I 
> don't have another Windows device, so the problem is either A) my 
> Linux computer can't talk to Windows or B) something besides the 
> firewall is messing up on Windows.
Good work.
It tells me that the mDNS info is coming out of the windows box 
(multicast), but that all the requests for detailed information are 
not.. (either not being received or not being responded to)

Since you've checked that the firewall is not blocking mDNS traffic, 
something else must be...
1) First option: winswitch + mDNS is broken on windows. That's unlikely, 
but I could have missed it, I will check at the earliest opportunity.
2) More likely, something is preventing bonjour from operating properly 
on windows. So I would use normal network diagnostic tools (telnet, 
tcpdump, etc) to figure out where things get stuck, comparing it with 
the traffic from a working setup.
Assuming that the problem is indeed from mdns, you may be able to get 
more help on a list dedicated to it.

A potential workaround, which I have not used in a long time, is the 
"reverse multicast" option of winswitch. This would have to be enabled 
on *all* the clients, and would require an extra port to be punched 
through their firewalls.. not ideal.


> On Mon, Feb 14, 2011 at 11:36 PM, Antoine Martin 
> <antoine at devloop.org.uk <mailto:antoine at devloop.org.uk>> wrote:
>     Can you login via ssh as that user?
>     Multicast is tricky but you are right: if it has connected before,
>     it should be ok.
>     Try running avahi-discover to browse the services it advertises.
>     The quick-connect window does use ssh if you select it, which
>     should not be necessary since you have disabled the firewalls, but
>     is worth trying anyway.
>     Note: the server should be running on the system before you
>     attempt to connect. If the applet is running, it should have
>     started a server for you already (unless you disabled it in the
>     options).
>     The accounts do not have to be the same, it shouldn't make much
>     difference unless you start fiddling the user account multicast
>     filter ("match username").
>     If all else fails, you can run the server in debug mode and send
>     me the log output (starting when you attempt to connect if possible):
>     winswitch_server --debug-mode
>     Cheers
>     Antoine
>     On 15/02/11 10:19, Jimi Bove wrote:
>         I forgot to add, I think it might have something to do with
>         the users. I can't figure out how to create users the
>         computers can log into, but I don't know how they could log in
>         to some random user. I mean it requires a password. How do I
>         set all that stuff? And does the fact that the usernames of
>         the accounts on both computers are the same, as are the
>         usernames connected to their local servers, change anything?
>         On Mon, Feb 14, 2011 at 7:17 PM, Jimi Bove
>         <jimijames.bove at gmail.com <mailto:jimijames.bove at gmail.com>
>         <mailto:jimijames.bove at gmail.com
>         <mailto:jimijames.bove at gmail.com>>> wrote:
>            I'm trying to get my Linux and Windows computers connected with
>            this program and it just refuses to work. When I first
>         tried it, I
>            launched winsitch_applet through the terminal in Linux. The
>         tray
>            icon didn't appear, but the server started and the Windows
>            computer automatically connected. After that incident, the tray
>            icon now appears and both computers see each other, but
>         they can't
>            connect. I've tried every setting with both firewalls disabled,
>            and I don't know what else to try. The fact that it worked once
>            rules out multicast issues, doesn't it?

More information about the shifter-users mailing list