[winswitch] xpra issuses

Randy thejunk.b at gmail.com
Sun Apr 28 19:13:52 BST 2013

On Sunday, April 14, 2013, Antoine Martin wrote:
> On 04/07/2013 10:25 PM, Randy wrote:
> > On Sunday, March 31, 2013, Antoine Martin wrote:
> >> Wait, ... are you trying to use NX or Xpra sessions?
> > 
> > xpra
> > 
> > OK, so I started over.  I am using 2 machine, one is a laptop, the other
> > a desktop.  Both of these machine worked with each other before I
> > upgaded from the older version.  Both machines run debian wheezy 64 /w
> > kde.  The desktop (TV) is hardwired to my local network, the laptop
> > (BumbleBee) uses wifi.  I am able to ssh back and forth between machine
> > manually with out issue and run gui apps from cli.
> > 
> > To start over I uninstalled both winswitch and xpra from both machines. 
> > Then I manually deleted the .winswitch and .xpra folders from users
> > ~/user.  Then I reinstalled both packages and reinstall the dependant
> > packages from synaptic. Neither machine has selinux installed.
> > 
> > I have not modifed the default config except to enable debug.  I get no
> > joy trying to run apps remotly.  The servers seem to connect to each
> > other correctly.  I am able to remotly launch guvcview (webcam app) on
> > the desktop from the laptop, but I am still seeing the app briefly
> > appear on the laptop then dissapear with a popup message that I can not
> > interpret.  I also don't see that message text in the logs.
> > 
> > If I go over to the desktop the app is there and I can reconnect to it
> > and it displays just fine locally.
> > 
> > I have tared the config files and log files off both machine and they can
> > be seen at
> > https://www.dropbox.com/sh/trsi9d82yvsuuk0/yiXmoIi-jk
> > if you have issues reading them let me know and we can try something
> > else.
> > 
> > 
> > Thanks
> Sorry for the late reply, I've skimmed through your log files and found
> this in laptop/applet-20130406-224841.log:
> ****
> [NULL @ 0x35ef8a0] Value 4686111960511545344.000000 for parameter 'b'
> out of range
> (snip)
> A process has ended with a probable error condition: process ended by
> signal 6
> ****
> Looks to me like there are problems with x264. I can tell you are using
> x264 from this line in the server log:
> 2013-04-06 22:52:38,420 using x264 as primary encoding
> You should be able to workaround this problem by defining another
> default encoding, either in /etc/xpra/xpra.conf or in ~/.xpra/xpra.conf
> I suspect this is yet-another problem caused by the API changes to
> libav.. I accepted a patch to make it work with newer versions, which
> seems to have caused endless problems with 99% of the versions currently
> deployed instead.
> I'll try to run a VM with wheezy/+-testing and see if I can reproduce.
> I also found this in desktop/applet-20130406-225118.log:
> ****
> 2013-04-07 07:00:31,910 Password matches!
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/dist-packages/wimpiggy/util.py", line 26, in
> do_get_property
>     return getattr(self, getter)(pspec.name)
>   File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 316,
> in do_get_property_client_contents
>     return self._composite.get_property("contents")
> AttributeError: 'NoneType' object has no attribute 'get_property'
> 2013-04-07 07:00:32,083 Connection lost
> ****
> That's an odd one, but probably not the cause of your problems. I think
> it is a consequence of it.
> Looks like we're trying to make calls on a window which is not/no-longer
> managed.
> Have you got a screenshot or copy of the "popup message that I can not
> interpret"?
> Thanks
> Antoine
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

So I finally got a chance to play with xpra a little.  To start with there was 
an update so I installed it.  Now I at least get a properly titled window on 
the remote host.  When it first launched guvcviewer I had the control window 
and the camera window.  The control window was fully populated but the camera 
window was blank.  As soon as I tried to use the controls the window went 
white.  Trying to close either window fails, eventually the kde window manager 
asks if you want to force close.  Forcing the window closed from the winswitch 
menu seams to close the session but leaves the windows open.

I tried to get a screen shot of the error that use to pop up but it did not 
show up this time.

Short pause for dinner and some honey-do's.

Next I tried launching gimp remotly.  This time it acted just like before.  I 
was able to get a screen shot of the error.

Then I changed the default seamless session type to nx on the desktop, but not 
via the config files, and tried again, same results.  Looking at the information 
menu item for the session it showed the session type as xpra.  So I rechecked 
the settings and confirmed that I had successfully changed it, and yes.  So I 
restarted winswitch.  Then I went to the laptop and changed the default 
session type to nx and restarted winswitch there too.  The I relaunched 
guvcviewer with the same results as before, captured the error in a 
screenshot.  I then checked the menu info item and it still shows the session 
type as xpra, hmmm.  I reconfirmed that the settings are set to nx and grabbed 
some screenshots for you of the destop setup.

Apps started locally via winswitch are displayed correctly.

Vbox wm's can be moved between machines successfully, although starting them 
remotly does not seem to work correctly.  The vm is started but not displayed 
remotly untill it is fully up and then moved to the remote machine.  Not a big 
issue at this time for me.

So I decided a complete restart was in order on both machines.  After the 
rebooot I have a guvcviewer menu item that is not movable nor openable on 
either machine.

So to avoid confilct with that session I tried launching K3b (cd burning app) 
and it failed as before.  And checking the session type in the info menu item 
shows that it is still using xpra and not nx.  Looking at the desktop server 
settings from the laptop shows that it is set to use xpar, but looking at the 
server setting on the desktop shows it set to nx.  But if I go to the server 
tab it the setings and right click on the desktop server and check the 
settings there they show xpra as the seamless default and it can not be 
changed, hmmmm.  I was able to capture the screen error.

As I mentioned at the start the only thing that has been changed is that I 
updated xpra before this round of debugging.

What else can I try to assist you?

Oh yea, I did disable the firewalls after the reboot to be sure they were not 
the problem.

Autolaunch is enabled on the desktop but not on the laptop.

I also noted that when looking at the available servers on the desktop, the 
desktop server does not have ssh capablities, yet I ssh in and out of the 
desktop all the time, and I can successfully connect to it via winswitch.  It 
just does not seam to have ssh with its self.

OK. After rereading the instructions you sent me I discovered that I was not 
doing as you requested.  Guess I should not rely on my memory so much.

I have looked at the xpra.conf files and can not find anywhere that x264 
encoding is set.  A hardcoded defalut? The attached configs are as they exist 
before I enable a different encoding.  From /etc/xpra/xpra.conf

# Default encoding (not all encodings may be available in your environment):
#encoding = x264
#encoding = vpx
#encoding = png
#encoding = jpeg
#encoding = rgb24
#encoding = webp

is there one that would be better or worse?  Png seams to work fine.

After resting winswitch on both the laptop and the desktop I still have the 
old guvcviewer menu entry.  How do I make it go away?

Now to go play with the other machines to see if I can finally get them to work 

Thanks for the work around.

If I can do anything further to help debug let me know.

The image files and logs are at 

The old ones have been deleted.


If it ain't broke tweek it

More information about the shifter-users mailing list