[winswitch] xpra 0.14.10 - RPM installation issues

Utku Altunkaya utku at um-ic.com
Tue Oct 28 15:27:50 GMT 2014


We have several workstations running different Linux flavors, namely
CentOS 5.11, CentOS 6.5 and Fedora 20. I was able to update XPRA to
version 0.14.10 on all of them by running "yum update xpra", but a
regular "yum update" fails due to package issues.

* On CentOS 6.5, I also have the problem that was already reported. I
don't have the Continuous Release repo enabled, and even after a yum
cleanup, I still get the same error:

---> Package xorg-x11-drv-dummy.x86_64 0:0.3.6-3.el6 will be updated
---> Package xorg-x11-drv-dummy.x86_64 0:0.3.6-15.xpra2.el6 will be an
--> Processing Dependency: xserver-abi(videodrv-15) >= 0 for package:
--> Finished Dependency Resolution
Error: Package: xorg-x11-drv-dummy-0.3.6-15.xpra2.el6.x86_64 (winswitch)
           Requires: xserver-abi(videodrv-15) >= 0

I noticed that you've refreshed the repo and the package version was
incremented from xpra1 to xpra2, but that hasn't solved the issue somehow.

* On Fedora 20, I keep getting a package signing error:

Package python-pillow-2.6.1-1.fc20.x86_64.rpm is not signed

* I'm also experimenting with CentOS 7.0, and I cannot install xpra at
all. "yum install xpra" fails with

--> Processing Dependency: libfakeXinerama for package:
--> Processing Dependency: python-lz4 for package:
--> Finished Dependency Resolution
Error: Package: xpra-0.14.10-1.el7_0.x86_64 (winswitch)
           Requires: libfakeXinerama
Error: Package: xpra-0.14.10-1.el7_0.x86_64 (winswitch)
           Requires: python-lz4

When I check the repo (https://www.xpra.org/dists/CentOS/7.0/x86_64/) I
can see that several RPMs are available for both packages, but "yum list
libfakeXinerama" and "yum list python-lz4" returns nothing. Could the
repodata be outdated?

Best regards.
Utku Altunkaya


More information about the shifter-users mailing list