[winswitch] Xpra "can't open display" error

pxd at tuta.io pxd at tuta.io
Sun Apr 29 19:59:20 BST 2018


Hi,
Using Xpra 2.3-r19058 from the Xpra Debian buster repo (on client and server), I can't get the display to get sent over ssh from a headless VM to the VM's host machine.

>From the client machine, if I run:
xpra start ssh:hostname:102 --start-via-proxy=no

I get:
xpra initialization error:
 failed to identify the new server display
Error: failed to receive anything, not an xpra server?
  could also be the wrong protocol, username, password, or port
Connection lost

But `xpra list` on the host machine shows that display :102 was successfully started and live. (If I do the above without `--start-via-proxy=no`, I get the same errors and can see  the xpra command running with `ps aux`, but I can't connect to it, there are no xpra sessions found with `xpra list` and I have to manually kill the xpra process.) 

I can attach to the session without any client side errors with `xpra attach ssh:hostname:102`, but can't get any windows sent over the connection.

On the server, if I run `DISPLAY=:102 xterm`, I get "No protocol specified" and "xterm: Xt error: Can't open display: :102". Firefox similarly gives me "No protocol specified / Unable to init server: Could not connect: Connection refused / Error: cannot open display: :102".

I can start xterm through an ssh session with X-forwarding, so X is somehow working.

The full xpra start and Xorg commands as shown in ps aux are:
/usr/bin/python2 /usr/bin/xpra start :102 --start-via-proxy=no --env=XPRA_PROXY_START_UUID=(some long uuid) --daemon=yes --systemd-run=no
/usr/lib/bin/xorg/Xorg-for-Xpra-:102 -noreset -novtswitch -nolisten tcp +extension GLX +extension XRANDR +extension RENDER -auth /run/user/1000/xpra/Xauthority-102 -logfile /run/user/1000/xpra/Xorg.:102.log -configdir /run/user/1000/xpra/xorg.conf.d/9075 -config /etc/xpra/xorg.conf -depth 24 :102

Errors in Xorg.:102.log are:
(EE) Unable to open config directory: "/run/user/1000/xpra/xorg.conf.d/9075"
(EE) systemd-logind: failed to take device /dev/dri/card0: Operation not permitted
(EE) AIGLX: reverting to software rendering
and a bunch of (EE) Failed to load module something (module does not exist, 0), where "something" is mouse, kbd, libinput

Errors in :102.log are:
/bin/sh: 1: dbus-launch: not found
dbus-launch failed to start using command 'dbus-launch --close-stderr':
 exit code is 127
(but later there is the message "D-Bus notification forwarding is available")
And the log ends with "xpra is ready / printer forwarding enabled.... / 3.9GB of system memory"

The VM running the Xpra server is a fresh Debian Buster install (without any graphical desktop environment) where I just `apt-get install xpra`ed. Interestingly, on a fresh Debian Buster + Gnome 3 install, I get a similar issue with `xpra start` apparently failing but still starting the display and letting me connect with `xpra attach`. On that VM, I can get a window sent over if I add the flags ` --start-via-proxy=no --xvfb="/usr/bin/Xwayland -rootless -noreset` to the start command to use Gnome's Xwayland X server.

Any ideas of where to poke to get more information on what's going wrong?

Thanks!

Persimmon


More information about the shifter-users mailing list