[winswitch] trying to get started with xpra

Thomas Käfer kaefert at gmail.com
Tue Jun 5 23:16:07 BST 2018


Hey there!

Years ago I used parti + xpra and since I have a similar need again now I
wanted to use xpra again.

So I installed xpra through my repositories (Linux Mint 18.3 ~ Ubuntu
16.04) which gave me:
xpra 0.15.8+dfsg-1

Sadly none of the most basic tutorials seem to work.

$ xpra start :100 --start-child=gnome-terminal
keeps running, but results in this logfile:

$ cat .xpra/:100.log
/usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server
2018-06-05 23:45:20,196
2018-06-05 23:45:20,196 Xvfb command has terminated! xpra cannot continue
2018-06-05 23:45:20,196

Trying to attach to the still running xpra start process gives:
$ xpra attach
2018-06-05 23:54:40,847 xpra gtk2 client version 0.15.8 (r11211)
The program 'Xpra' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 288 error_code 2 request_code 154 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I think I remember that in the old times one needed to restart the system
after installing before having it work as it should. I tried that. Didn't
help.

I found this link which seems to suggest that the server part only works
using a root account:
https://github.com/dnschneid/crouton/issues/2676

So I tried that, which instead gave this log:
$ cat .xpra/:100.log
X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-97-generic x86_64 Ubuntu
Current Operating System: Linux RID04689-N550JV 4.15.0-22-generic
#24~16.04.1-Ubuntu SMP Fri May 18 09:46:31 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-22-generic
root=UUID=af827427-05e7-4a3b-8ddb-03e9aa5ae267 ro quiet splash vt.handoff=7
Build Date: 13 October 2017  01:57:05PM
xorg-server 2:1.18.4-0ubuntu0.7 (For technical support please see
http://www.ubuntu.com/support)
Current version of pixman: 0.33.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/home/kaefert/.xpra/Xorg.:100.log", Time: Tue Jun  5
23:59:00 2018
(++) Using config file: "/etc/xpra/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
2018-06-05 23:59:00,998 Warning: zlib is the only compressor enabled
2018-06-05 23:59:00,999  install and enable lzo or lz4 support for better
performance
2018-06-05 23:59:00,999 Warning: 'rencode' packet encoder not found
2018-06-05 23:59:00,999  the other packet encoders are much slower
2018-06-05 23:59:00,999 server uuid is 26a9c4d0426b41c385acc3976739cdf8
2018-06-05 23:59:01,141 pulseaudio server started with pid 23259
W: [pulseaudio] main.c: This program is not intended to be run as root
(unless --system is specified).
E: [autospawn] core-util.c: Home directory not accessible: Permission denied
W: [autospawn] lock-autospawn.c: Cannot access autospawn lock.
E: [pulseaudio] main.c: Failed to acquire autospawn lock
2018-06-05 23:59:01,150 using notification forwarder:
DBUSNotificationsForwarder(org.freedesktop.Notifications)
2018-06-05 23:59:01,169 started child 'gnome-terminal' with pid 23282
2018-06-05 23:59:01,170 xpra server version 0.15.8 (r11211)
2018-06-05 23:59:01,170 running with pid 23242
2018-06-05 23:59:01,170 Warning: pulseaudio has terminated shortly after
startup.
2018-06-05 23:59:01,170  Either fix the pulseaudio command line or use the
'pulseaudio=no' option to avoid this warning.
2018-06-05 23:59:01,170  usually, only a single pulseaudio instance can be
running for each user account, and one may be running already
2018-06-05 23:59:01,260 you may want to disable mdns support to avoid this
2018-06-05 23:59:01,264 xpra is ready.
Xlib:  extension "GLX" missing on display ":100".
2018-06-05 23:59:01,512 child 'gnome-terminal' with pid 23282 has terminated

Connecting to this server ran as root using
$ xpra attach
gives the exact same output as before (and opens no gnome-terminal)

Can somebody help me? Is the xpra version 0.15.8+dfsg-1 that I got from the
Linux Mint18.3/Ubuntu16.04 repository broken? Or is xpra not usable on
current linux desktop systems in general? What do you suggest would be the
easiest way to get it functional, if thats possible on this system?

Thank you,
Kind regards,
Thomas K.


More information about the shifter-users mailing list