[winswitch] Windows to Linux shadow: Wrong keyboard mapping

Antoine Martin antoine at nagafix.co.uk
Thu Mar 14 02:58:29 GMT 2019


On 13/03/2019 22:13, Frank Loemker wrote:
> Hello,
> 
> On 3/13/19 2:35 AM, Antoine Martin via shifter-users wrote:> On 12/03/2019 22:39, Frank Loemker via shifter-users wrote:
>>> Hello,
>>>
>>> I am currently trying to get shadow access from Windows 10 to Ubuntu Linux
>>> 14.04 working. The server on the Linux box is using 1.0.13-r21370 64-bit.
>>> The client on Windows is 1.0.13-r21474 32-bit. I tried as well 2.4.3-r21365
>>> and 0.17.4-r12925 under Windows with exactly the same result.
>>
>> Please try 2.4.3 at both ends, or even 2.5rc3 from the beta channel.
>> Keyboard mapping when shadowing is unlikely to work with older versions.
>> (especially for the server version)
> 
> That unfortunately does not work. I am stuck on the server with Ubuntu 14.04,
> and that has Python 3.4.3 and Python 2.7.6. Python3 is not supported on the
> server and Python 2.7.6 is too old. Updating Python2 with something from a
> PPA did not work as well as too many other packages depend on exactly the
> correct Python 2.7.6 version.
Ubuntu 14.04 is going to be EOLed at the end of next month, it might
just be easier to upgrade to a newer version, and skip 16.04 if you can.

If you're willing to use xpra without SSL support, and with some ugly
warnings in places, you can build trunk (2.5rc4) as of this changeset:
http://xpra.org/trac/changeset/22080/xpra

Cheers,
Antoine


More information about the shifter-users mailing list