[winswitch] Main problems with xpra 0.7.0 and winswitch 0.12.17

Davide Varvello varvello at yahoo.com
Thu Oct 11 13:46:22 BST 2012

>>>>      Moreover mouse right click is extremely slow.
>>> It isn't here. What application are you using?
>>> Is it just the right click?
>> It seemed to me. I tried 0.7.0 for a such limited amount of time because it was useless to me, I couldn't do anything with keyboard so I tried to copy and paste via right click and I noticed it was very slow.
>OK, so it's not the actual right click that is slow but the clipboard
>lookup. What was the app you were testing with? Copying from one app to
>another? (there is no clipboard support on macos due to lack of a usable
>clipboard api on osx)

No, I copied chars in the same app because shift and ctrl didn't work. I had to write "(" and I couldn't because shift had no effect so I copied from another ( 

>> Then I rollbacked to xpra version 0.6.2 but I kept  winswitch (v 0.12.17) client on osx lion and it's fine
>>>>      SocketConnection(/home/davide/.xpra/machine-100 - )
>>>>      2012-10-10 23:28:37,702 Connection lost
>>>>      2012-10-10 23:28:37,713 Connection lost
>>>>      2012-10-10 23:28:38,089 Lost WM selection, exiting
>>> Looks like you are running another window manager (or "xpra upgrade"?)
>>> on this display so Xpra exited. This is normal, you can only have one
>>> window manager at a time.
>> Tell me more, how can I spot it?
>You should be able to spot it with a simple process list, or using:
>DISPLAY:100 xlsclients

DISPLAY:100 xlsclients returns "command not found"

>I bet this is just another xpra instance doing an upgrade since you are
>using winswitch: it will capture all the xpra sessions it finds to make
>them available to you via winswitch.
>You can turn off this behaviour in .winswitch/server/protocols/xpra.conf
>by setting:
>Or stop winswitch when testing pure xpra sessions.
>> Anyway following is the log I have now using 0.6.2:
>> [dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
>> [dix] Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType, removing from list!
>> 2012-10-11 07:47:35,895 using notification forwarder: DBUSNotificationsForwarder(org.freedesktop.Notifications)
>> 2012-10-11 07:47:35,895 xpra server version 0.6.2
>> 2012-10-11 07:47:35,926 xpra is ready.
>> 2012-10-11 07:47:45,404 New connection received: SocketConnection(/home/davide/.xpra/machine-100 - )
>> 2012-10-11 07:47:45,552 Connection lost
>> 2012-10-11 07:48:27,072 New connection received: SocketConnection(/home/davide/.xpra/machine-100 - )
>> 2012-10-11 07:48:27,073 Connection lost
>> 2012-10-11 07:48:27,148 New connection received: SocketConnection(/home/davide/.xpra/machine-100 - )
>> 2012-10-11 07:48:27,150 New connection received: SocketConnection(/home/davide/.xpra/machine-100 - )
>> 2012-10-11 07:48:27,283 Connection lost
>> 2012-10-11 07:48:27,285 Connection lost
>> 2012-10-11 07:48:27,711 Lost WM selection, exiting
>> 2012-10-11 07:48:27,711 xpra is terminating.
>> 2012-10-11 07:48:27,733 xpra end of gtk.main().
>> upgrading: not cleaning up Xvfb or socket
>> Finally, just for your info, when I rollbacked to 0.6.2, apt forced me to revert python-wimpiggy to 0.6.2, but probably something was missing because /usr/bin/winswitch_server --daemon didn't started, so I followed your faq (http://winswitch.org/downloads/debian-repository.html?dist_select=lucid) and installed winswitch. 

>Where did you install winswitch from previously?
I installed it a long time ago using the same instructions here http://winswitch.org/downloads/debian-repository.html?dist_select=lucid


>I haven't tested latest winswitch with xpra 0.6.2, it should work, but
>there are some debian packaging tricks in there so maybe that's the problem.
>> Cheers
>>  Davide
>>> Cheers
>>> Antoine

More information about the shifter-users mailing list