[winswitch] XPRA_SOCKET_DIR=~/.xpra: Command not found

Antoine Martin antoine at nagafix.co.uk
Thu Sep 6 06:02:51 BST 2012

On 09/05/2012 10:24 PM, Bob Tennent wrote:
> I'm trying to upgrade from xpra-0.3.2 to xpra-0.5.3 on Centos-6.3. When
> I do
> xpra --ssh="ssh -p2202" attach ssh:remotehost:100
> (which worked before) I get
>    XPRA_SOCKET_DIR=~/.xpra: Command not found.
>    2012-09-05 11:15:10,957 Connection lost
> Why?
I've just tried it with the same versions and I cannot reproduce your 
problem. I can connect just fine via ssh, before and after upgrading the 
server session to 0.5.3.

You may be able to workaround the issue by using:
xpra --socket-dir="" --ssh="ssh -p2202" attach ssh:remotehost:100
(but sine I do not understand the problem.. this is just a wild guess)

Why does your system try to run the environment variable as if it was a 
command.. This is what xpra should execute in your case:
ssh -p 2202 -T $rhost XPRA_SOCKET_DIR=~/.xpra .xpra/run-xpra _proxy :100
Can you try running this by hand? It won't work as an xpra client, but 
do you get the same error message from ssh?

Here's something a little easier to understand that you can try:
ssh -T $YOURHOST XYZ=1 "env | grep XYZ"
You should see: "XYZ=1"
And if you use an invalid command, it does print that command's name and 
not the environment setting:
ssh -T $YOURHOST XYZ=1 invalid_foo
bash: invalid_foo: command not found

The only other option for debugging your problem is to post:
xpra -d all attach (...)
Please also post your /etc/xpra/xpra.conf (and ~/.xpra/xpra.conf if you 
have created one)

Hope this helps!


> This is the output from xpra info on the remote system:
>    Xlib:  extension "RANDR" missing on display ":100.0".
>    build_bit=32bit
>    build_cpu=i686
>    build_date=2012-09-05
>    built_by=buildbot
>    built_on=winswitch.org
>    clients=0
>    clipboard=1
>    encodings=png,jpeg,rgb24,x264,vpx
>    gtk_version=[2, 18, 9]
>    local_modifications=0
>    max_desktop_size=[3840, 2560]
>    password_file=
>    platform=linux2
>    potential_clients=0
>    pulseaudio=1
>    pygtk_version=[2, 16, 0]
>    python_version=[2, 6, 6]
>    randr=0
>    revision=1481
>    root_window_size=[3840, 2560]
>    session_name=
>    start_time=1346858008
>    version=0.5.3
>    windows=0
>    Connection lost
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list