[winswitch] XPRA_SOCKET_DIR=~/.xpra: Command not found

Bob Tennent rdtennent at gmail.com
Thu Sep 6 12:46:28 BST 2012

 >|On 09/06/2012 12:02 PM, Antoine Martin wrote:
 >|> On 09/05/2012 10:24 PM, Bob Tennent wrote:
 >|>> I'm trying to upgrade from xpra-0.3.2 to xpra-0.5.3 on
 Centos-6.3. When
 >|>> I do
 >|>> xpra --ssh="ssh -p2202" attach ssh:remotehost:100
 >|>> (which worked before) I get
 >|>>    XPRA_SOCKET_DIR=~/.xpra: Command not found.
 >|>>    2012-09-05 11:15:10,957 Connection lost
 >|>> Why?
 >|Found a better explanation and a potential fix.
 >|Are you using a non-bash login shell with that user by any chance?

Yes: tcsh.

 >|The simple fix is here:
 >|Can you try this beta package and see if the problem goes away:

That problem goes away but there seem to be new (unrelated?) problems.
When I start on xterm on the remote server, the client crashes:

  Traceback (most recent call last):
    File "/usr/lib/python2.6/site-packages/xpra/client_window.py", line
  210, in do_realize
      if self.is_toplevel():
  AttributeError: 'ClientWindow' object has no attribute 'is_toplevel'
  Segmentation fault

I tried to build a patched xpra-5.3.3 using the src.rpm but get

ERROR: cannot find a valid pkg-config package for ['libswscale']

(even before patching).

Bob T.

More information about the shifter-users mailing list