[winswitch] xpra 0.6.1 -- feedback

Antoine Martin antoine at nagafix.co.uk
Sat Sep 15 06:11:20 BST 2012

On 09/15/2012 08:36 AM, Dmitry Smirnov wrote:
> Hi Antoine,
> Thank you for your work. I hope you don't mind some feedback:
No, quite the opposite, I welcome it!

> First of all I think changing default encoding from PNG wasn't such a good 
> idea. By default visual quality is now degraded comparing to previous 
> versions.
It shouldn't be. x264 (and to a lesser extent vpx) offer almost lossless
visual quality, with much higher compression.

> (I know I can override in config but I would prefer high quality 
> defaults). Personally I feel very uncomfortable with new defaults.
Can you specify the application, and link characteristics?
How do I get this lower visual quality you experienced?

Note: there was a bug in the 0.6.0 server which caused quality to
degrade (and not recover quickly enough), this is one of the reasons for
the 0.6.1 release.
(upgrading the client alone would not be enough to fix this issue)

This undocumented debugging trick can dump all the encoding quality and
batch delay calculation messages to the server log: start your server with:
XPRA_DEBUG_LATENCY=1 xpra start ...

> Of course first thing I tried is to change encoding as soon as I connected to 
> 0.6.1 instance using 0.6.1 as client. When I've chosen "vpx" as compression, 
> xpra (client) crashed as soon as I moved mouse over remote application.
> The following was printed to console:
> 2012-09-15 11:26:24,544 Connection lost
Both of those stacktraces show that the server crashed or disconnected,
the real cause is in the server logs...

> Reconnecting to server wasn't possible. Server log had only one error:
> 	[swscaler @ 0x3eca5e0] 1x1 -> 1x1 is invalid scaling dimension
Hah, there is some code to avoid windows that small with x264 (it only
handles even dimensions), looks like vpx needs a similar workaround for
a different reason (YUV to RGB conversion with swscale seems to not
support very small dimensions), so here is the fix:
I cannot find the minimum dimensions specified anywhere, so I've used
the same restrictions as x264: avoid 1 pixel wide or high dimensions.
(will backport to old branches too)


> To fix I ran "xpra upgrade :N" on server and I was able to attach again.
> All the best,
> Dmitry.
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list