[winswitch] xpra issuses

Antoine Martin antoine at nagafix.co.uk
Thu May 2 10:45:37 BST 2013

> So I finally got a chance to play with xpra a little.  To start with there was 
> an update so I installed it.  Now I at least get a properly titled window on 
> the remote host.  When it first launched guvcviewer I had the control window 
> and the camera window.  The control window was fully populated but the camera 
> window was blank.  As soon as I tried to use the controls the window went 
> white.  Trying to close either window fails, eventually the kde window manager 
> asks if you want to force close.  Forcing the window closed from the winswitch 
> menu seams to close the session but leaves the windows open.
Hmm, that's odd. Looks like something has crashed.

> I tried to get a screen shot of the error that use to pop up but it did not 
> show up this time.
> Short pause for dinner and some honey-do's.
> Next I tried launching gimp remotly.  This time it acted just like before.  I 
> was able to get a screen shot of the error.
Can we see it?

> Then I changed the default seamless session type to nx on the desktop, but not 
> via the config files, and tried again, same results.  Looking at the information 
> menu item for the session it showed the session type as xpra.  So I rechecked 
> the settings and confirmed that I had successfully changed it, and yes.  So I 
> restarted winswitch.  Then I went to the laptop and changed the default 
> session type to nx and restarted winswitch there too.  The I relaunched 
> guvcviewer with the same results as before, captured the error in a 
> screenshot.  I then checked the menu info item and it still shows the session 
> type as xpra, hmmm.  I reconfirmed that the settings are set to nx and grabbed 
> some screenshots for you of the destop setup.
Hmmm, that seems overly complicated:
* you can change the settings from the UI, can you not? No need to
restart then.
* there are global settings as well as per-server settings, maybe you
only changed the former?

> Apps started locally via winswitch are displayed correctly.
> Vbox wm's can be moved between machines successfully, although starting them 
> remotly does not seem to work correctly.  The vm is started but not displayed 
> remotly untill it is fully up and then moved to the remote machine.  Not a big 
> issue at this time for me.
Right, we're probably trying to connect to it before it is ready.

> So I decided a complete restart was in order on both machines.  After the 
> rebooot I have a guvcviewer menu item that is not movable nor openable on 
> either machine.
guvcviewer is doing some video stuff, it may try to bypass the
compositor (xpra) to get the video onscreen and therefore may not work
I will try it when I get a chance.

> So to avoid confilct with that session I tried launching K3b (cd burning app) 
> and it failed as before.
Which is?
>  And checking the session type in the info menu item 
> shows that it is still using xpra and not nx.  Looking at the desktop server 
> settings from the laptop shows that it is set to use xpar, but looking at the 
> server setting on the desktop shows it set to nx.  But if I go to the server 
> tab it the setings and right click on the desktop server and check the 
> settings there they show xpra as the seamless default and it can not be 
> changed, hmmmm.  I was able to capture the screen error.
My head just exploded.
* use the start application dialog instead, it lets you choose a lot
more options, including the session type
* or hold the "special" key ("Shift" by default) when you select an app
in the start menu, which will bring a dialog similar to the "start
application dialog" and includes protocol selection (xpra, nx..)

> As I mentioned at the start the only thing that has been changed is that I 
> updated xpra before this round of debugging.
> What else can I try to assist you?
> Oh yea, I did disable the firewalls after the reboot to be sure they were not 
> the problem.
> Autolaunch is enabled on the desktop but not on the laptop.
> I also noted that when looking at the available servers on the desktop, the 
> desktop server does not have ssh capablities, yet I ssh in and out of the 
> desktop all the time, and I can successfully connect to it via winswitch.  It 
> just does not seam to have ssh with its self.
Your server log will probably tell you that your ssh configuration does
not allow "SSH X11 forwarding".

> OK. After rereading the instructions you sent me I discovered that I was not 
> doing as you requested.  Guess I should not rely on my memory so much.
> I have looked at the xpra.conf files and can not find anywhere that x264 
> encoding is set.  A hardcoded defalut? The attached configs are as they exist 
> before I enable a different encoding.  From /etc/xpra/xpra.conf
> # Default encoding (not all encodings may be available in your environment):
> #encoding = x264
> #encoding = vpx
> #encoding = png
> #encoding = jpeg
> #encoding = rgb24
> #encoding = webp
> is there one that would be better or worse?  Png seams to work fine.

> After resting winswitch on both the laptop and the desktop I still have the 
> old guvcviewer menu entry.  How do I make it go away?
xpra list
xpra stop :NNNNN
(or just kill it)

> Now to go play with the other machines to see if I can finally get them to work 
> :)
> Thanks for the work around.
> If I can do anything further to help debug let me know.
> The image files and logs are at 
> https://www.dropbox.com/home/Public/winswitch
> The old ones have been deleted.


> Thanks
> Randy

More information about the shifter-users mailing list