[winswitch] Ubuntu 13.04 as host - permission problems on xpra start

Antoine Martin antoine at nagafix.co.uk
Tue May 7 17:45:29 BST 2013

On 05/07/2013 11:39 PM, Stephen Gutknecht (hilltx) wrote:
> On Tue, May 7, 2013 at 11:20 AM, Antoine Martin <antoine at nagafix.co.uk> wrote:
>> On 05/07/2013 11:14 PM, Stephen Gutknecht (hilltx) wrote:
>>> I'm going to try to keep this simple ;) I didn't have any of these
>>> problems with numerous Ubuntu 12.10 hosts... but clean installs of
>>> Ubuntu 13.04 x64 are giving me problems.
>>> xpera start on the host runs into various permission issues:
>>> 1. /dev/tty0 permission problem. A hacky chmod gets past that.
>>> 2. /dev/tty8 permission problem. A hacky chmod gets past that.
>>> 3. xf86EnableIOPorts permission problems
>>> I'm trying xpra v0.10.0
>> 0.10.0 is not even in beta yet... 0.9.0 is likely to work better.
>> That said, I don't think it will solve any of these errors.
>>> Anyone able to get this working on Ubuntu 13.04?
>> Sorry, not installed the latest Ubuntu yet, not particularly keen on
>> finding out what they have managed to break this time around.
>> Sounds like these permissions issues are to do with Xvfb/Xdummy rather
>> than xpra itself. Trying the other option may work around that.
> I've tried several times to figure out the syntax/method to shift to
> Xdummy - what is the syntax with recent builds?
Examples are already included in your /etc/xpra/xpra.conf

> To clarify: I am doing a total clean install (format of the partition,
> not an upgrade) of Ubuntu 12.10 / Ubuntu 13.04 on a system with Intel
> HD 4000 Graphics drivers (Ivy Bridge chipset) - no special Nvidia or
> ATI drivers installed here. Ubuntu 12.10 - no problems, Ubuntu 13.04
> and these permission problems come up.
Client graphics drivers should make no difference here.

> One more install comment: ubuntu 13.04 seems to not have libwebp2 so I
> manually installed a .deb file I found at
> http://ubuntu.wikimedia.org/ubuntu/pool/universe/libw/libwebp/libwebp2_0.1.3-3_amd64.deb
> to get xpra to install.
According to what I am seing here, libwebp has been available for Ubuntu
since Oneiric:

> I tried xpra 0.8.8-1 at one point too, same problems.


More information about the shifter-users mailing list