[winswitch] xpra unuseable on CentOS 5

Lukas Haase lukashaase at gmx.at
Sat Nov 8 10:44:09 GMT 2014

Hi Antoine,

> > Before I file a bug report I want to try it again here because I think
> I got a better handle what is wrong.
> I still think a ticket is a better place for this.

Ok, I'll move it there then.

> > So in my application, when a child window opens, I realized that it largly reacts to mouse input but
> not to keyboard input.
> > As mentioned, this does not happen from the beginning but starts
> somewhen "randomly".
> > Reconnecting with "xpra attach" does not help, only restarting the
> whole server helps.
> xpra upgrade?

(Not) Funny, just tried it, now it does not react at all to any keyboard input.
(No error output on either side).

> [...]
> What toolkit is this application written in?

The application is Cadence. 
Good question, I assume it is plain X11.
ldd spits out:

        libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000003417600000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003414600000)
        librt.so.1 => /lib64/librt.so.1 (0x0000003415200000)
        libXt.so.6 => /usr/lib64/libXt.so.6 (0x0000003415a00000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x0000003416600000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00002b55038e9000)
        libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x00002b5503b63000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003418e00000)
        libelf.so.1 => /usr/lib64/libelf.so.1 (0x0000003416a00000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x0000003423800000)
        libm.so.6 => /lib64/libm.so.6 (0x0000003414a00000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x000000341f800000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003413e00000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003414200000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x0000003418200000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002b5503de8000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003413a00000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x000000341be00000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x000000341a600000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x0000003416e00000)
        libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x0000003414e00000)
        libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x0000003415600000)

> Can you post sample code?

Which sample code?
Source code? That's gonna be difficult because Cadence is closed source, proprietary and protected.

> [...]
> > Is there anything I could do w/o upgrading from CentOS 5?
> No. Nothing worth the effort.

Oh man, I could cry.

I just looked, the "hack" (where I installed xpra and parts of python as user in my home directory) which worked so nicely is "xpra v0.11.2" but it uses "Python 2.7.5+".

I think it's nearly impossible to get this machine upgraded but I may try it at least. If so, what would be the python and/or CentOS version with which everything should work? CentOS 6?


More information about the shifter-users mailing list