[winswitch] A simple script to get started with xpra on Ubuntu

Thom Jentoft thom.jentoft at gmail.com
Thu Sep 4 09:31:09 BST 2014

Ok, I was trying to check if I indeed need some kind of script to run xpra,
because AFAICT the last time I tried it, it just worked "out of the box",
when I installed it with apt-get. Not this time.

I have 64-bit server Ubuntu 14.04 LTS on the server (hosted by
interserver.net) and 64-bit Ubuntu 14.04.1 LTS on the desktop

On the server I'm installing xpra:

su -
apt-get update
apt-get install sudo xpra -y

(server is a "minimal" installation, and indeed, it doesn't have sudo
Then run it:

xpra start :100 --start-child=xterm --bind-tcp=

On the client I run:

$ xpra attach tcp:
xpra client version 0.12.3
2014-08-06 15:33:50,709 PyOpenGL warning: missing accelerate module
2014-08-06 15:33:50,709 PyOpenGL warning: missing array format handlers:
numpy, numeric, vbo, vbooffset
2014-08-06 15:33:50,709 OpenGL Version: 2.1 Mesa 10.1.3
2014-08-06 15:33:51,103 detected keyboard: rules=evdev, model=pc105,
2014-08-06 15:33:51,104 desktop size is 1920x1080 with 1 screen(s):
2014-08-06 15:33:51,104   ':0.0' (508x285 mm) workarea: 1871x1056 at 49x24
2014-08-06 15:33:51,104     HDMI2 (598x336 mm)
2014-08-06 15:33:51,507 server: Linux Ubuntu 14.04 trusty, Xpra version
0.12.3 (r6075)
2014-08-06 15:33:51,519 Attached to tcp: (press
Control-C to detach)

And nothing else ever gets displayed (no graphics window, no nothing)

How do I make it work?

More information about the shifter-users mailing list