[winswitch] troubleshooting assistance?

basd basd1 at fastbk.com
Tue Apr 7 18:46:36 BST 2015

Hello to the list, and thank you Antoine for helping me subscribe!

Basically I am hoping for assistance in finding the right troubleshooting approach and I apologize
for the long email.  But first, some description of my experience running winswitch.

I have been *extremely* happy with Winswitch, it is now a "core application" for my computers.  I
create a VPN using neorouter and so I don't even need to open up ports to the internet.  Generally
speaking, installation has been flawless.  I have built openSuSE noarch rpms from the tar.bz source
files and multiple versions have worked fine.  I am currently using Window Switch 0.12.20 and xpra

My systems are on openSuSE, although I also have one or two Windows 8.1 computers running also. 
Interestingly, I can resize desktop sessions in linux clients, but not in windows.  The resizing is
extremely convenient because my monitors all have different sizes when I pass the running desktop
from one computer to another.

Winswitch has been very stable -- I can leave desktops running for days.  The other "amazing" thing
is that I get a much faster and better connection than when I connect directly to an x0vncserver on
the same server.  I assume that is from server parameter settings that I don't know about, but
Winswitch does?

I have not been able to use applications, but using a full desktop session is my preference in any
event.  I have used iceWM desktops and then switched to XFCE.  (My computers all run KDE Plasma as
their regular desktop.  But, the other thing that is great about Winswitch is that I can run
multiple linux desktops at the same time, such as iceWM, XFCE, Enlightenment, etc.  Great for
testing and learning the different desktops.

OK, but now to my problem:  I just did a reinstall on one of my better servers and I cannot get a
connection with the server socket for desktop sessions.  (Strangely, this is the first install on
which I have been able to run winswitch application sessions -- but they aren't stable).

As far as I know, I have done everything exactly the same as I did on every other computer (and on
this one before I reinstalled the operating system.)  A possible difference is that I am running the
3.19 kernel and openSuSE 13.2 -- My prior servers have always on openSUSE 13.1. (Right now, openSuSE
13.1 (x86-64) / linux kernel 3.11.10-25-desktop / KDE 4.14.6.  Winswitch is running on other
computers running openSuSE 13.2 -- and even KDE Plasma 5 -- but I have never tested whether they
work as servers because these are client computers.

So here is where I am at with my problem server: winswitch runs.  It will work as a client to my
other server.  It will launch an application window (but it does not hand-off correctly to any other
computer and it leaves "ghost" unknown applications in the menu when it closes).

When I attempt to run a desktop session it tells me it cannot connect to socket (connection
refused).  I can rule out firewall issues because this happens even when I attempt to start a
desktop on the local server (  It also then gives me a notification that "winswitch is
already running, which seems strange."

I can run x0vnserver and connect my client computers -- so I know vnc is accessible. 

I have run winswitch from command line and tried to cure any dependency issues.

I have run "zypper dup" -- distribution update -- to make sure all of my software is [presumably]

I deleted the .winswitch directory and the .xpra directory to get rid of legacy parameters.

I installed xpra-0.14.21.

It's pretty important to me to get this server running.  In fact, I may try a reinstall of openSuSE
13.1 just to see if I can get it the Winswitch server running again.

But, if someone here can suggest a methodical approach to troubleshooting the problem, I would
rather get Winswitch working in the current install.

Thank you!

Barrington Daltrey

More information about the shifter-users mailing list