[winswitch] openSUSE 13.1 Winswitch progress

Antoine Martin antoine at nagafix.co.uk
Sat Apr 25 12:18:09 BST 2015

On 25/04/15 07:58, basd wrote:
> I put a symbolic link from /usr/lib/python2.7/site-packages/winswitch to
> /usr/lib64/python2.7/site-packages/ -- and now my server is providing VNC desktop sessions!
> I really don't know what I am doing in building rpms -- is this something I could write into the
> spec file?  I thought of this fix because I was staring at my xpra.spec file and noticed in the
> files section that files went to lib64, not lib.  (Haven't tried the same "fix" on my 13.2 server
> yet ...)
Oh, the joys of packaging.
And it gets worse when you start looking at the location for the
nautilus python extensions.
What a mess!
> And in other news:
> I decided to try and run Xpra from command line and see what happens. 
> *On my opSu 13.1 server, the log file reports (from Xorg) that "no screens found".
(Which log file?)
Are you sure xpra is configured and installed properly? With Xdummy? or
with Xvfb?
> *On my opSu 13.2 server, Xpra mostly works -- initially I just started an xterm, then when I tried
> desktop mode I discovered I did not have Xephyr installed, so after fixing more dependencies, it
> works locally at least.
> *Big HOWEVER, though -- when I run "xpra stop :100", it reboots my server!
That's just wrong. Whatever opensuse or the DE are doing here, it needs
> *Smaller however: when I logout the client iceWM session, it invokes the KDE4 logout dialog on the
> server! (Expected behavior would be to log out of Xpra iceWM session as happens with VNC desktops.
> -- In both these instances, I am running the xpra client on the server via "localhost".)
Again, that sounds wrong.
We are moving further and further away from multi-user setups with every
layer of complication they add to the desktop.
> *When I tried to access the xpra desktop session via command line xpra from my opSu 13.1 machine, I
> got a number of errors
>   (1) libwebp5.so missing -- even though after I repackaged the rpm, install no longer complains
> about libwebp5.so.
That's a build / packaging issue.
>   (2) connection refused -- if this is not related to libwebp5, then there continues to be some sort
> of authentication problem.  This was seemingly solved in winswitch by the symbolic link mentioned
> above, but in this instance I am running xpra without winswitch, so that is not a factor.  Also
> tried to use Winswitch to start an xpra desktop session, but that didn't work either.
Winswitch may be stealing your xpra sessions to make them available via
the GUI, turn off that option and it should be fine.
>   (3) no gdkgl, which is a problem on both servers, but merely prevents openGL as far as I can tell.
That's only useful for accelerated rendering on the client. (and you
will need pygtkglext and pyopengl as well).


More information about the shifter-users mailing list