[winswitch] interesting development

Frédéric Henry-Couannier fhenryco at yahoo.fr
Tue May 26 09:53:51 BST 2015

hello ,
Now i have tested successfully xpra  for application forwarding  between a Linux server station and an odroid (client) . However i cant make it work for the full desktop forwarding.
I tried on the server:xpra start --start-child="Xnest :200 -ac -geometry 800x600+24" :100
DISPLAY=:200 fluxbox&and get message
Xlib:  extension "RANDR" missing on display ":200"

?? what does it mean i have no idea
Then on the client xpra attach ssh:SERVERUSERNAME at SERVERHOST:100gives me a black screen

     Le Mardi 7 avril 2015 23h54, basd <basd1 at fastbk.com> a écrit :

 In my earlier post I mentioned problems connecting to server socket for desktops.  However, with
implementation of xpra-0.14.21 I am able to run xpra sessions.

Interestingly, I can spawn multiple child windows from an xpra remote application that function as
windows on the client -- but can be moved collectively to another client.  This is a reasonable
substitute for desktop sessions.

Back when I was using iceWM desktop for remote sessions, I wrote a bash script that provides a menu
for launching favorite programs.  Using that script, I can launch an xterm session in xpra, run my
menu bash script and launch separate programs from it.  For instance, I can run firefox, dolphin
file manager, libreoffice and even Yast2 (openSuSE's administrative control panel).  So far, this
appears to give me the same functionality as running these programs in an iceWM desktop session,
with the additional advantage that the xpra child windows function as windows on the client desktop
itself.  Both server and clients are running KDE 4.14 -- this is interesting, because winswitch.org
FAQs seem to indicate applications are problematic to run under KDE/Plasma.

I had to mark ssh_tunnel=False in the server.conf file, since ssh tunnelling is not working for me.

Other points:

*I have concluded that my installs apparently cannot do ssh tunnelling. I never tried to implement
this because I use a VPN, so I have always used direct connections.  Ssh is active on the server and
I can use sftp, ssh, etc. to the server.
*Sometimes when exiting xpra windows, a "ghost" xpra session is left in the winswitch menu list, as
"unknown".  I can't access or kill this session.
*opSU 13.1 repositories have libwep4 series and current xpra requires libwep5, which is available in
opSU 13.2 repositories.

For reference:

Server 1:
6 core AMD x86_64
openSuSE 13.1
linux kernel 3.11.10-25-desktop
KDE platform 4.14.6
winswitch-0.12.20 in an rpm I built from sources under opSU 13.1
xpra-0.14.4 (also in an rpm I built from sources)

remote desktops work / remote applications do not work

Server 2:
8 core AMD x86_64
openSuSE 13.2
linux kernel 3.19.3-1-gf10e7fc-desktop
KDE platform 4.14.6
winswitch-0.12.20 in an rpm I built from sources under opSU 13.2
xpra-0.14.21 (also in an rpm I built from sources under opSU 13.2)

remote desktops do not work / remote applications do work, per above description.

Barrington Daltrey

shifter-users mailing list
shifter-users at lists.devloop.org.uk


More information about the shifter-users mailing list