[winswitch] xpra full desktop

basd basd1 at fastbk.com
Tue May 26 22:17:15 BST 2015

Some further discussion, in case it's of interest.   Below are my notes regarding (1) attempts to
run a custom script via "custom command" in winswitch; (2) running an xpra Xephyr desktop and
retrieving it from another client; (3) finding the xpra session via Avahi browser.

I created a script (xephyr_launch) in ~/bin on the server and run it as a custom command from

This works:

xterm -e firefox

This does not work:

firefox &

This does work:

firefox &disown

(interestingly, closing kwrite also closes firefox)

These crash the server (and also require deletion of ~/.winswitch in order to recover the winswitch

Xephyr :200 &disown

xterm -e Xephyr :200 &disown

Separately, using a "konsole" command line AND NOT running winswitch (winswitch will kill the
running xpra session), this works:

xpra start --start-child="Xephyr :200" :100

DISPLAY=:200 icewm

xpra attach :100

(icewm seemingly does not require the &, I just hit a <return> after icewm started up and got
another command prompt.)

There is a delay before "DISPLAY=:200 icewm" can be run -- first time icewm said no X was running,
then I attached and detached, ran the DISPLAY command again, icewm attached to :200 and then I ran
"xpra attach :100" again.

For testing purposes, I keep having to restart the computer to clear the server, xpra stop :100
doesn't necessarily leave the system clean so I can run the xpra start command again.  So, I'd like
to try running this from a script instead of a console, but I will probably crash the xpra :100 and
display :200 and have to reboot the server to make further tests.

In any event, once I have display :200 running and attached via xpra attach :100 on the server, this
will bring it onto my client computer:

xpra attach ssh:

The benefit of running it this way is that there is no xterm window paired up with the remote
desktop, I just have the remote desktop.  The disadvantage is that I'm not able to use the Winswitch
app to attach and detach.

But, I'm not up-to-speed with what you have running on Android, so I don't know how to attach this
session to android.

Also, I notice this session does show up in the Avahi Zeroconf Browser, though I don't specifically
know how to make use of that (other than to be aware the session is available).

Lastly, because I run neorouter VPN, Avahi also tells me I can connect via the VPN, so xpra attach
ssh: works as well (but I have to clear the ssh fingerprint or I get an error warning

(BTW, on this test I am getting a pretty fast connection and not having the problem with keystrokes
repeating or not executing that I often have when I run xpra individual applications.)

More information about the shifter-users mailing list