[winswitch] issue with forwarding x to a lower res monitor from a virtual Xvfb

Antoine Martin antoine at nagafix.co.uk
Mon Nov 16 06:23:14 GMT 2015

On 15/11/15 16:51, Zenny wrote:
> On 11/15/15, Antoine Martin <antoine at nagafix.co.uk> wrote:
>> On 15/11/15 14:44, Zenny wrote:
>>> Hi,
>>> xpra is very interesting, but I am encountering an issue or say cannot
>>> figure out exactly how to achieve the following.
>>> 1. Start a xvfb based virtual x instance in a resolution say 4k
>>> (3840x2160) in one machine (server) with say libreoffice impress, and
>>> broadcast using 'xpra shadow :10"
>> Please include the exact command line used for starting the Xvfb and
>> libreoffice.
> $ Xvfb :10 -screen 0 4096x2160x24+32 -fbdir /var/tmp &
> $ export DISPLAY=:10.1
Could this be a typo? I've used this instead:
export DISPLAY=:10
> $ libreoffice & / i3 & / lxsession -s LUBUNTU -e LXDE
Both libreoffice and lxsession crash when I try on Fedora 23, with Xvfb 
or Xdummy.
> $ xpra shadow :10
>>> 2. Access that instance from another machine (laptop) using 'xpra
>>> attach ssh:hostname:10'
> $ xpra attach ssh:HOSTNAME:10
>>> 3. Screencapture the :10 inside the same machine at 4K.
>> Using which tool?
> initially with ffmpeg and then with xwd / maim
Command lines?
I started an xterm with "xterm -geometry 600x100" and captured it fine 
with scrot.
Both with Xvfb and Xdummy.
>>> But it does not allow me to capture in 4K but at the same resolution
>>> as of the rendering laptop.
>> I have tested here with Xdummy and that worked fine.
> With Xdummy, once I attach to the remote machine with xpra, the ffmpeg
> fails as it says "the capturing region lies out of the range." or
> something like this.
Having the exact command line and error message may help.
>>> I checked Xdummy related to Ubuntu instruction at
>>> https://www.xpra.org/trac/wiki/Xdummy, but to no avail.
>> Are you using Xvfb or Xdummy? What distribution and version?
> Tried with Xvfb, didn't work and then with Xdummy. Still experimenting. ;-)
> $ lsb_release -a
> LSB Version:	core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
> Distributor ID:	Ubuntu
> Description:	Ubuntu 14.04.3 LTS
> Release:	14.04
> Codename:	trusty
> xpra  is at v0.15.8-2 and xvfb is at v1.15.1-0ubuntu2.7
Xdummy is problematic on Ubuntu - it is disabled for most Ubuntu versions.
>>> Any hints would be highly appreciated. Thanks!
>> You may also be interested in the following 0.16 features:
>> * ability to NOT change the virtual display to match the client's
>> resolution using:
>> XPRA_RANDR=0 xpra start ...
>> See:
>> http://xpra.org/trac/changeset/11229
>> Shadow mode is A LOT less efficient than the regular "start" mode.
>> * desktop scaling, which allows you to upscale or downscale the server
>> resolution when displayed on the client:
>> http://xpra.org/trac/ticket/976
>> So you could render at 4k and display at 2k for example (though the main
>> purpose of this ticket is to do the opposite to save bandwidth).
>> * "sync-xvfb" fix for screen capture tools:
>> http://xpra.org/trac/ticket/988
> Very interesting. Is there a binary of this dev release?
There are fairly recent builds here:


> Thanks for taking time to reply.
> Cheers,
> /z
>> Cheers
>> Antoine
>>> Cheers,
>>> /z
>>> _______________________________________________
>>> shifter-users mailing list
>>> shifter-users at lists.devloop.org.uk
>>> http://lists.devloop.org.uk/mailman/listinfo/shifter-users
>> _______________________________________________
>> shifter-users mailing list
>> shifter-users at lists.devloop.org.uk
>> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list