[winswitch] OS X El Capitan cannot run Xpra

Ryan Orendorff ryan at orendorff.io
Tue Oct 27 19:00:19 GMT 2015


I have been trying to run xpra on a computer that had a fresh install of El Capitan, but have not been able to get the application to launch thus far. When I try to run with the current release, I get the following.

>  /Volumes/Xpra/Xpra.app/Contents/MacOS/Xpra attach ssh:url:21
2015-10-27 11:54:21,052 xpra gtk2 client version 0.15.7 (r10824)
dyld: Library not loaded: /Users/osx/gtk/inst/lib/libgstreamer-0.10.0.dylib
  Referenced from: /Volumes/Xpra/Xpra.app/Contents/Helpers/gst-plugin-scanner
  Reason: image not found

I saw there was a ticket that included the library not being found (ticket #984), and that this had been fixed in the beta releases. So I tried the newest beta release that I could find that had a revision number higher than 10885 (a fix was specified to be in versions after this). 

> xpra attach ssh:url:21
2015-10-27 11:46:12,964 Xpra gtk2 client version 0.16.0-r11058
2015-10-27 11:46:12,965  running on Mac OSX

If I then kill the xpra process, I get some standard output I would expect before it closes.

got signal SIGTERM, exiting
2015-10-27 11:46:19,228 OpenGL_accelerate module loaded
2015-10-27 11:46:19,233 OpenGL enabled with ATI Radeon HD 6750M OpenGL Engine
2015-10-27 11:46:19,260  using default keyboard settings
2015-10-27 11:46:19,267  desktop size is 4480x1440 with 1 screen(s):
2015-10-27 11:46:19,267   nerv.local (1580x508 mm - DPI: 72x72)
2015-10-27 11:46:19,267     monitor 1 2560x1440 at 1920x0 (903x508 mm - DPI: 72x72)
2015-10-27 11:46:19,267     monitor 2 1920x1200 at 0x200 (677x423 mm - DPI: 72x72)
2015-10-27 11:46:19,268  scaled using 1.5 x 1.5 to:
2015-10-27 11:46:19,268   nerv.local (1580x508 mm - DPI: 48x48)
2015-10-27 11:46:19,268     monitor 1 1706x960 at 1280x0 (903x508 mm - DPI: 47x48)
2015-10-27 11:46:19,268     monitor 2 1280x800 at 0x133 (677x423 mm - DPI: 48x48)

What also confuses me is that I have another machine that I upgraded to El Capitan (so from Yosemite -> El Capitan), and xpra works in those conditions (using the same binary I used in Yosemite). I tried transferring that binary to my fresh install machine but xpra fails to run.

Have you guys noticed this problem?


More information about the shifter-users mailing list