[winswitch] Question about Xpra, OpenGL, and Xming-Mesa

Antoine Martin antoine at nagafix.co.uk
Fri Dec 1 18:50:15 GMT 2017

On 02/12/17 00:32, Michael Segev wrote:
> Hi Antoine,
> Thank you for the prompt response. I added the "+extension GLX" to the
> command line, so now my command in the file looks like this:
> xvfb = Xvfb +extension GLX +extension Composite -screen 0
> 5760x2560x24+32 -dpi #96 -nolisten tcp -noreset -auth $XAUTHORITY
Looks OK.

> Unfortunately, the application is still refusing to start and gives me
> the same "no OpenGL found in context" error. 
Can you run simple test applications like "glxgears" or "glxinfo"?

> Yesterday I was digging around the Xpra site and I saw that there seems
> to be an issue with nvidia graphics cards and OpenGL
> (https://xpra.org/trac/wiki/Xdummy).
Not the graphics card itself, but the proprietary nvidia driver.
glvnd is the future solution to this particular problem. (but I don't
recommend you go down that route if you are struggling already)

> The graphics card for my local
> windows PC (which, in X terminology, I guess would be called the
> "server"?) is an Nvidia GeForce 960M, and I saw on the Xpra site that
> VirtualGL is a potential solution for this. I just spent the past 6
> hours reading the documentation for VirtualGL on their site 
> (https://cdn.rawgit.com/VirtualGL/virtualgl/2.5.2/doc/index.html), but
> the documentation was incredibly confusing. For instance, I could not
> for the life of my figure out this
> image: https://cdn.rawgit.com/VirtualGL/virtualgl/2.5.2/doc/vgltransport.png.
> Shouldn't the "application" be sitting in on the "client "side, since in
> X terminology the client side is the remote server where I'm running the
> application? And, following the X terminology, shouldn't I have to
> download VirtualGL for the "server" side--in this case, my local Windows
> PC? There was no "server" downloads on the OpenGL site for Windows PC's,
> only for "client" software which linked to a software called "Exceed",
> of what /I think /is a commercialized version of Xming? And in fact, on
> the latest download files for VirtualGL, the client software for Windows
> was completely gone--there was just a "VirtualGLUtils" package that
> seemed to just provide benchmarking tools.
VirtualGL is expected to run on your xpra server's display, on Linux.
xpra does not use Xming or anything like it, it is a native application
and all the OpenGL rendering will happen on the xpra server side.

> Terminology confusion aside, I tried installing VirtualGL for my remote
> Ubuntu 16.04 linux box (the "client"?) just because I had no idea what
> to do at this point, and then tried running the following (with Xming
> and X11 tunnelling enabled over Putty):
> "vglrun java -jar MyApp.jar"
> but then VirtualGL gave me the error:
> "[VGL] ERROR: Could not open display 0."
VirtualGL delegates OpenGL calls to an existing accelerated X11 display.
Looks like you don't have one running on :0, or you don't have access to it.
If you have one, but it's not on :0, then you need to use the "-d" switch.
If you don't have an X11 display running, then you might be able to
remove the nvidia driver and then use software rendering. Or you can
start one to be able to use VirtualGL with it.

> So at this point, I'm, completely confused. Any help/clarification you
> could provide would be greatly appreciated; perhaps I should also ask
> over at the VirtualGL support thread and see if they say anything.
Their answer is likely to be what I said above, or "RTFM".


> Thank you for your time,
> Michael
> On Thu, Nov 30, 2017 at 8:35 PM, Antoine Martin via shifter-users
> <shifter-users at lists.devloop.org.uk
> <mailto:shifter-users at lists.devloop.org.uk>> wrote:
>     On 01/12/17 01:11, Michael Segev via shifter-users wrote:
>     > Hello,
>     >
>     > My situation is as follows:
>     >
>     > I'm currently on a Windows 10 machine that has Xpra, Xming-Mesa (Xming with
>     > OpenGL support), and PuTTY installed. I am trying to run a GUI java app
>     > that uses OpenGL on a remote Linux (Ubuntu 16.04) machine and have it
>     > display back on my PC using Xpra.
>     >
>     > I can successfully run the application when I just use Xming-mesa. However,
>     > when I add Xpra into the equation, the GUI java app fails to start and
>     > throws this error:
>     >
>     >  OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current
>     > thread
>     >
>     > But if i shut down the Xpra server and just connect using Xming-mesa, the
>     > application starts fine; so I'm somehow inclined to believe that there is
>     > some conflict here involving Xpra and OpenGL.
>     >
>     > Any advice you could provide to fix this would be greatly appreciated.
>     The easiest way is to add "+extension GLX" to your xvfb command line in
>     /etc/xpra/conf.d/55_server_x11.conf
>     This will be the default for Ubuntu 16.04 in the upcoming 2.2 release.
>     This solution is not accelerated.
>     For more options, including OpenGL acceleration see:
>     https://xpra.org/trac/wiki/Usage/OpenGL
>     <https://xpra.org/trac/wiki/Usage/OpenGL>
>     Cheers
>     Antoine
>     >
>     > Thank you.
>     > _______________________________________________
>     > shifter-users mailing list
>     > shifter-users at lists.devloop.org.uk
>     <mailto:shifter-users at lists.devloop.org.uk>
>     > http://lists.devloop.org.uk/mailman/listinfo/shifter-users
>     <http://lists.devloop.org.uk/mailman/listinfo/shifter-users>
>     >
>     _______________________________________________
>     shifter-users mailing list
>     shifter-users at lists.devloop.org.uk
>     <mailto:shifter-users at lists.devloop.org.uk>
>     http://lists.devloop.org.uk/mailman/listinfo/shifter-users
>     <http://lists.devloop.org.uk/mailman/listinfo/shifter-users>

More information about the shifter-users mailing list