[winswitch] Problems with recent builds of XPRA

Alex Wood alex at alex-wood.org.uk
Wed Jun 7 15:06:26 BST 2017


I've noticed a few problems recently with xpra (just xpra, I don't use the
full winswitch package) build for both windows and linux (Ubuntu).  My setup
is I use xpra to run programs from my Ubuntu 17.04 x64 server on my Windows
10 x64 Desktop.  I tend to start the program via the cli on the server and
then connect to that session via windows.  The Ubuntu builds that are giving
me problems are the x64 variants of builds 16025/6:

16025 - complains  opengl support is missing and bombs out

16026 - says that xpra for python 2.7 is not installed and bombs out.  I
tried to install xpra for python using pip, but it failed to build (problem
linking to ffmpeg).

I also notice the deb file for 16026 is quite a bit smaller than usual.  I
can still get everything to work if I use build 15981 though and use
apt-mark hold xpra to stop it updating to the problematic build versions.


On Windows I have to use  either x64 build 15800, as build 15924 (the one
you also use as the main download for  x64 Windows) says it is corrupt when
I try and run the installer, and is only about 13Mb in size, as opposed the
usual 55-60Mb range.   I was just wondering if this is just a temporary
glitch, or if there is a new dependency or something that I've missed and
need to download for these builds?

Thanks for your help.


More information about the shifter-users mailing list