[winswitch] Unable to attach from Windows

Antoine Martin antoine at nagafix.co.uk
Mon Aug 6 16:20:57 BST 2018

On 06/08/18 16:42, Daniele Polencic wrote:
> On Mon, 6 Aug 2018 at 14:25, Antoine Martin via shifter-users
> <shifter-users at lists.devloop.org.uk
> <mailto:shifter-users at lists.devloop.org.uk>> wrote:
>     On 06/08/18 14:46, Daniele Polencic via shifter-users wrote:
>     > Hello,
>     >
>     > I installed Xpra on a Linux VM.
>     >
>     > From my mac I can SSH into the VM with:
>     > ssh workspace
>     > and I can attach to an Xpra session with:
>     > xpra attach ssh:workspace
>     >
>     > I tried to do the same on Windows. I can connect to SSH with:
>     > ssh workspace
>     Is this openssh? from mingw? cygwin?
> I used Cmder http://cmder.net
That's an important piece of information.
But not as important as the fact that you were using ssh keys...

> Tried with Cygwin, same error.
It isn't supposed to work. I was just asking where the 'ssh' command
came from.
>     > I tried with the UI and it silently fails. I installed the following
>     > binary: https://xpra.org/dists/windows/Xpra-x86_64_Setup.exe
>     > The Xpra client on Windows is: v1.0 14492
>     That's way too old. (over a year and a half's worth of fixes) 
>     > The Xpra client on Mac is: xpra v1.0.12-r19800
>     Try the latest stable 2.3.x builds for both macos and windows.
>     There is absolutely no reason to use the 1.x branch on MacOS or MS
>     Windows unless you run Windows XP or MacOS versions older than 10.9
> Thanks for pointing that out. The links on the home page are pointing to
> version 1 of the client. I should have checked.
AFAIK, this is not true:
# ls -la windows/Xpra-x86_64_Setup.exe
windows/Xpra-x86_64_Setup.exe -> Xpra-x86_64_Setup_2.3.2-r19729.exe
# ls -la windows/Xpra_Setup.exe
windows/Xpra_Setup.exe -> Xpra_Setup_2.3.2-r19729.exe
# ls -la MacOS/x86_64/Xpra-x86_64.pkg
MacOS/x86_64/Xpra-x86_64.pkg -> Xpra-x86_64-2.3.2-r19729.pkg

I even double checked and downloaded the canonical links on the home
page then compared the checksums.

>     > The Xpra server running on Ubuntu is: xpra v2.3.2-r19729
>     > Is there anything else I should try?
>     Does your system log on the server show a connection attempt at all?
>     If so, does the ssh authentication succeed?
> As I mentioned, I can see a prompt in both Mac and Windows when I type
> "ssh workspace".
> The connection is working.
I meant when xpra is doing the same thing.

>     Try to specify your username and maybe even the password on the command
>     line:
>     xpra_cmd attach ssh://username:password@host/ 
> I'm using private keys to connect to SSH, so I won't be able to test the
> password.
And here is the essential piece of information that was missing!
(..)> After more digging, I noticed that Xpra client uses plink and not the
> standard ssh command. Since plink doesn't know how to look into
> .ssh/config the configuration is not picked up and the connection fails.
> Plink can read saved sessions from Putty, though. After I configured the
> session in Putty I was able to connect to Xpra with:
> "C:\Program Files\Xpra\Xpra_cmd.exe" attach ssh:workspace
> Mistery unravelled.
Be aware that xpra 2.4 will switch to paramiko by default, to switch
back to plink, you will need to add:
ssh=plink -ssh -agent
To your user's ~/.xpra/xpra.conf

> Thanks for helping me out.


More information about the shifter-users mailing list