[winswitch] Can't start xpra session

Antoine Martin antoine at nagafix.co.uk
Thu Aug 30 04:22:37 BST 2018

On 30/08/18 01:30, Anthony Stone via shifter-users wrote:
> Antoine,
> I am puzzled by the following. I tried to start an xpra session on my
> usual server, and got this on the client:
> Am I doing something daft, or is there a bug? The xpra start command has
> worked many times before -- I usually use ctrl-R to retrieve the
> previous start command each time, rather than retyping it.
Directly on the server (ie: via ssh), try to start the session locally:
xpra start :100 --start="gnome-terminal --window-with-profile=Blue"

Then check it has started:
xpra list

And if not, have a look at the server log file and send it here if you
can't make sense of it.

At this point, you should be able to connect (use "attach" instead of
"start" and with the display number specified above with start):
xpra attach ssh://yourhost/100

If things still fail, please provide the full details (full os version
at both ends, etc).
Just be aware of the recent incompatibility with non-bash login shells.
(this should be fixed in the next stable update)


> On both server and client, I have:
>  $ xpra --version
> xpra v2.3.3-r20112
> Anthony Stone

More information about the shifter-users mailing list