[winswitch] How to install local unprivileged Xpra server?

Antoine Martin antoine at nagafix.co.uk
Wed Jan 24 05:57:49 GMT 2018

On 24/01/18 12:47, Ben Mishkanian via shifter-users wrote:
> Hi,
> I am trying to build and install from source an Xpra 2.2.3 server as an unprivileged user on CentOS 7. I ran setup.py and it seems to complete fine, although it prints a bunch of brotli errors saying it failed to minify various files.
You can ignore those errors or turn off the brotli feature, see:
./setup.py --help

> In any case it produces the xpra binary, but when I run `xpra -h` it says (This xpra installation does not support starting local servers.)
Please always include the exact command lines that you have used so we
can help you with that.
Also specify which CentOS 7 you are using, CentOS versions older than
7.2 are not supported in xpra versions 2.x and later, see:

Be aware that your home made build will be severely degraded and may not
work as expected. (performance, features, security, etc)

> How can I find out why it can't start local servers? setup.py showed that the "server" build switch is set to "Y".
My guess is that you're not setting the PYTHONPATH correctly.
You should be installing into a directory:
./setup.py install --home=./install
Then adjusting PATH and PYTHONPATH accordingly.

> Thank you,
> Ben
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list