[winswitch] [xpra] HTML5 client: open link clicked on remote machine in local browser

Matteo Ipri matteo.ipri at arpm.co
Wed May 30 22:34:24 BST 2018

PS: maybe some of my replies/questions are out of topic. Where is the best
place to make such discussions?

On Wed, May 30, 2018 at 6:10 PM, Antoine Martin <antoine at nagafix.co.uk>

> > How can I add the open-url=yes option to the HTML5 client?
> Sorry, I completely missed the part where you had said that you wanted
> to use the HTML5 client for this.
> This feature had only been implemented in the python client until now.
> For the HTML5 client, please try:
> https://xpra.org/trac/ticket/1862#comment:2
> And add comments there.

Thank you very much. I am reinstalling xpra now enabling the beta
repository, too.
I'll test and I will comment below the ticket.
If I should install from source, I will try it, too.

> > I started xpra with the following command
> > $ xpra start \
> > --daemon=no \
> > --bind-tcp= <> \
> > --html=on \
> > --ssl=off \
> > --bandwidth-limit=500kbps \
> > --bell=no \
> > --pulseaudio=no \
> > --webcam=no \
> > --mdns=no \
> > --system-tray=no \
> > --clipboard-direction=both \
> > --file-transfer=yes \
> > --forward-xdg-open=yes \
> > --start=xterm \
> > --xvfb="Xvfb -dpi 96 -noreset -nolisten tcp +extension GLX +extension
> > RANDR +extension RENDER +extension Composite -screen 0 1600x900x24+32"
> If you are using this switch to use a specific initial resolution, there
> are easier ways, see:
> http://xpra.org/trac/ticket/1132#comment:1

Thanks for the tip!
Yes, I need to specify the initial resolution, otherwise windows of
launched apps are waaaay too big.
I'll try the solution with environment variable.
I also used that switch because I understood from the wiki that I have to
use that switch to benefit of the pros of Xdummy, but maybe I got it
I was trying to get the best performance running xpra on Amazon Web
Services EC2 instance without dedicated GPU.

> > I run a reverse proxy with TLS termination in front of xpra.
> I hope the proxy is fast. The websocket connections degrade pretty
> quickly when any measurable latency is added.

Yes, I discovered this myself. I am investigating ways to change my virtual
network. Thanks for the advice anyway! :-)

> > Any suggestion?
> Oops sorry. I overwrote the GPG key with the old one by mistake, and
> half the repositories still had the old Release file.. So much fail.
> Try again and things should just work.

Yes, now it works on my PC running Arch Linux, too.
Thank you very much for the quick fix!

> Cheers,
> Antoine

Thank you very very much again!

More information about the shifter-users mailing list