[winswitch] [ANNOUNCE] Xpra 4.0

Antoine Martin antoine at nagafix.co.uk
Thu May 14 13:10:29 BST 2020


On 14/05/2020 19:06, carl langlois wrote:
> Hi,
> just try to upgrade and got this.
> 
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Calculating upgrade... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help resolve the situation:
> 
> The following packages have unmet dependencies:
>  xpra : Conflicts: python3-xpra but 3.0.9-r26132-2 is to be installed
That's weird, maybe you didn't have 3.0.9 installed and I did, because I
didn't hit this issue when I tested upgrades.

This should work:
apt-get remove xpra python3-xpra python2-xpra
apt-get install xpra
(in v4 there is only one 'xpra' package, which is the python3 variant)

Cheers,
Antoine

> E: Broken packages
> Regards
> Cerl
> 
> On Thu, May 14, 2020 at 4:56 AM Antoine Martin via shifter-users
> <shifter-users at lists.devloop.org.uk
> <mailto:shifter-users at lists.devloop.org.uk>> wrote:
> 
>     On 13/05/2020 17:48, carl langlois via shifter-users wrote:
>     > Hi,
>     > Great job guys.
>     > Can we expect build for Ubuntu 19.10?
>     Oops, thanks for the reminder.
>     The Ubuntu 19.10 builds were failing and needed a couple of tweaks.
>     The fixed 4.0 packages are in the Ubuntu Eoan repository now.
> 
>     Cheers,
>     Antoine
> 
> 
>     > Thanks and regards
>     >
>     > Carl
>     _______________________________________________
>     shifter-users mailing list
>     shifter-users at lists.devloop.org.uk
>     <mailto:shifter-users at lists.devloop.org.uk>
>     https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 



More information about the shifter-users mailing list