[winswitch] record audio via pulseaudio with xpra?

Antoine Martin antoine at nagafix.co.uk
Sun Sep 20 06:17:20 BST 2020


On 20/09/2020 04:01, Massimiliano Dal Cero via shifter-users wrote:
> Hi all,
> when run a xpra environment with this command:
> 
> $ xpra start-desktop :2020 --start="fluxbox" --start="xrandr -s
> 1280x720x16" --no-daemon --bind-tcp=0.0.0.0:14500 --html=on
> --resize-display=no --encoding=h264 --speaker=on --start="google-chrome"
> 
> I can hear the sound on the remote client (via html5 client).
> 
> Also, on the "server" I can record screen with ffmpeg, but without audio
> (second pulseserver is running, but is recognized only the main pulseserver
> of the system).
> 
> $ ffmpeg -f x11grab -video_size "1280x720" -framerate 25 -i :2020.0 -f
> pulse -i 1
> 
> So, my question now is:
> how can i record both screen and audio?
In the same way that you are telling x11grab that your display is at
":2020", you need to tell the pulse grabber that your pulseaudio server
is at a specific location.

For doing that, the easiest way is to run this command from within the
desktop session, as this will have the correct environment variables
already setup.

Alternatively, you can extract those environment variables from your
desktop session and use them with your ffmpeg command line.

I have not tested it, but this one might be enough:
xpra info | grep env.PULSE_SERVER

Cheers,
Antoine


> 
> Thanks a lot & best regards :)
> Max
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> https://lists.devloop.org.uk/mailman/listinfo/shifter-users
> 



More information about the shifter-users mailing list