[winswitch] deb-src for the tigervnc packages provided on winswitch repo

Amit Aronovitch aronovitch at gmail.com
Mon Nov 5 21:49:16 GMT 2012

On 11/05/2012 01:16 PM, Antoine Martin wrote:
> Hi Amit,
> On 11/05/2012 05:51 AM, Amit Aronovitch wrote:
>> Dear Antoine,
>> Thanks for Window Switch, and all related work available from this
>> project (the work on xpra in particular).
>> It seems like you are the only distributor of tigervnc debian packages
>> these days. However, I could find only binaries on your repository (no
>> deb-src). Could you please distribute the packaging sources (or provide
>> a link on the website in case you already do)?
> I don't have deb-src I am afraid. These packages are hacked together by
> running the build directly in the tigervnc source then calling "dpkg -b"
> with the hard-coded control files...
> It's ugly and not the right way to do it, but that's what I have and it
> works for my purposes...
> This was discussed a while back on a mailing list and I assumed that
> someone from Debian would eventually pick it up and do it properly,
> unfortunately this does not seem to have happened yet.

Well, as Dmitry had pointed out in the previous message (thanks for the 
link!), there is a collab-maint project based on Joachim Falk's 
packaging. It seems like they have made some progress and are waiting 
for a deb-dev to sponsor it.

The packages provided by Joachim are amd64 (which fortunately matches my 
hardware), and I was able to install.
I still have some problems (namely: the xsession dies immediately), but 
at least the server starts and things be can further debugged (if/when I 
find the time...)

Note that they had moved to tigervnc 1.2.0, which has a different set of 
commandlines than 1.1.0, and is not recognized by WinSwitch.

>> Another issue is that I could not make the vncserver work (on debian sid).
>> The first problem was that the Xvnc binary contained hard-coded
>> references to /usr/src/tigervnc-1.1.0/xorg.build (which is not
>> available, unless you compile the package from source...). I got over
>> that by symlinking /usr/lib/x86_64-linux-gnu into 'lib' in that directory.

> Yuk, sorry about that. That is indeed the path I've used for building.
> The thing is that I don't use vncserver myself, so I am unlikely to
> notice such breakage... I couldn't find this path in the vncserver
> script when I looked at it - which is odd.

It is not in the perl script, but in the compiled Xvnc binary (use the 
strings command to search it, or strace when running it).

>> However, now a different failure occurs, which I have not been able to
>> fully diagnose: as follows:
>> amit at penguin:~$ Xvnc :33
>> Xvnc TigerVNC 1.1.0 - built Jun  4 2012 08:17:48
>> Copyright (C) 1999-2011 TigerVNC Team and many others (see README.txt)
>> See http://www.tigervnc.org for information on TigerVNC.
>> Underlying X server release 10605000,
>> Mon Nov  5 00:16:02 2012
>>   vncext:      VNC extension running!
>>   vncext:      Listening for VNC connections on all interface(s), port 5933
>>   vncext:      created VNC server for screen 0
>> Fatal server error:
>> Failed to allocate core devices
>> amit at penguin:~$ dpkg --search `which Xvnc`
>> tigervnc-server: /usr/bin/Xvnc
>> amit at penguin:~$ strings /usr/bin/Xvnc | grep 'core devices'
>> Failed to allocate core devices
>> (strace does not reveal much more - it dies after successfully reading
>> the file /usr/share/fonts/X11/misc/cursor.pcf.gz ).
>> I have downloaded the source tarball for tigervnc 1.1.0 from
>> sourceforge, searched it, and was not able to find the string "allocate
>> core devices".
> The Xvnc server is built against the Xorg server source. To do things
> right, it should be built against the host's Xorg headers and
> dynamically linked. The versions I built are statically linked against
> Xorg 7.4 (see the build instructions in the tigervnc source)
> You should be able to find those messages in one of the downloads the
> build scripts grab before building everything.

It think I saw some discussion regarding this issue in the the link 
mentioned above: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=654924
(I did not follow up to see how they solved it though).

> As for the exact source of the breakage, I do not know. I've just
> re-built the binary DEBs for sid and still get the same error as you,
> you can find them here:
> http://xpra.org/beta/sid/
> I believe the tigervnc sid packages used to work fine, but I cannot
> remember 100% if I had tested everything.

Thanks for that.
At the moment, it seems like the right direction is trying to make 
winswitch work with tigervnc 1.2.0 (do you support it on other 
platforms?) and use Joachim's packaging (I'll have to see if I can solve 
my xsession issue).

>> It might come from some statically linked library used by Xvnc, or I
>> might have searched the wrong tarball. The precise sources used for
>> building the binary could help determine this. Or better yet, you, as
>> the packager, might have some insight into this problem.
> Hope the above helps... Ideas welcome.
> Cheers
> Antoine
> PS-FYI-RANT: Debian wheezy and sid seem to have broken /var/log/wtmp
> with some log rotation issue, so this makes testing Xvnc with winswitch
> harder.. solved by a reboot (otherwise local X11 sessions are not
> detected and cannot be shadowed with x0vncserver..)

Thanks for the info, and thanks Dmitry for the pointer to Joachim's effort.


More information about the shifter-users mailing list