[winswitch] Req for help: This server does not export any commands

martin re.martin at rocketmail.com
Mon Nov 26 13:11:09 GMT 2012

Hi all users and devs,

I am getting the following

"This server does not export any commands!"

I get this whenever I press "Start Application Session" or "Start
Desktop Session", so I suppose it's not a problem of xpra or vnc as both
of them "fail".

I actually am testing two machines, each one with it's own server.
Enabled, Connected and SSH columns show green ticks.
Configurations are pretty much the same for both servers.

Ssh forwarding is working, I tested with xclock xserver/client
interaction between the two hosts.
Avahi is working fine (servers are getting published, so no problems
Tried ticking and unticking "Match username" in both ends. No difference
Tried first with keys generated by winswitch, then generated my own
passwordless keys, and copied them to give passwordless ssh access.
Tried them and it works just fine ...
My distribution is debian squeeze.

I'm attaching my debug (winswitch_applet --debug_mode).

Can provide more data if needed.

I really want to use this magnificent piece of software!

Thanks in advance

More information about the shifter-users mailing list