[winswitch] Req for help: This server does not export any commands

Antoine Martin antoine at nagafix.co.uk
Tue Nov 27 09:30:55 GMT 2012


On 11/26/2012 08:11 PM, martin wrote:
> Hi all users and devs,
> I am getting the following
> "This server does not export any commands!"
Maybe you're hitting this recent bug:
If so, the beta builds here may fix this problem:
> I get this whenever I press "Start Application Session" or "Start
> Desktop Session", so I suppose it's not a problem of xpra or vnc as both
> of them "fail".
You're right, it doesn't get to that point, for whatever reason.
> I actually am testing two machines, each one with it's own server.
> Enabled, Connected and SSH columns show green ticks.
> Configurations are pretty much the same for both servers.
> Ssh forwarding is working, I tested with xclock xserver/client
> interaction between the two hosts.
FYI: winswitch does not use ssh forwarding unless you launch application
with "ssh mode" instead of xpra/nx/vnc.
Still good to know that works.
> Avahi is working fine (servers are getting published, so no problems
> here)
> Tried ticking and unticking "Match username" in both ends. No difference
> Tried first with keys generated by winswitch, then generated my own
> passwordless keys, and copied them to give passwordless ssh access.
> Tried them and it works just fine ...
> My distribution is debian squeeze.
> I'm attaching my debug (winswitch_applet --debug_mode).
The mailing list scrubs attachments, so please paste in a ticket, sorry
about that.
> Can provide more data if needed.
> I really want to use this magnificent piece of software!

> Thanks in advance
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list