[winswitch] Problem using Xpra client on Windows

Leith Bade leith.bade at anu.edu.au
Tue Nov 19 06:14:48 GMT 2013


I am trying to get the Windows Xpra client to use a saved SSH proxy chain from PuTTY.

When I run:

Xpra_cmd.exe attach -ssh="plink -load ANU"

I get this:

xpra client version 0.10.9


        Xpra_cmd.exe attach [DISPLAY]

        Xpra_cmd.exe detach [DISPLAY]

        Xpra_cmd.exe screenshot filename [DISPLAY]

        Xpra_cmd.exe info [DISPLAY]

        Xpra_cmd.exe version [DISPLAY]

        Xpra_cmd.exe shadow DISPLAY

(This xpra installation does not support starting local servers.)

Xpra_cmd.exe: error: cannot find a live server to connect to

So I tried again with

Xpra_cmd.exe attach :100 -ssh="plink -load ANU"

Then I got:

xpra client version 0.10.9

connection failed: 'module' object has no attribute 'AF_UNIX'

So I tried again with:

Xpra_cmd.exe attach ssh:server-host:100 -ssh="plink -load ANU"

2013-11-19 17:09:25,542 GL Extension GL_ARB_vertex_program available

2013-11-19 17:09:32,153 write connection reset for TwoFileConnection(ssh:server-host:100)

2013-11-19 17:09:32,154 Connection lost

2013-11-19 17:09:32,154 connection closed after 0 packets received (0.0 bytes) and 1 packets sent (0.0 bytes)

2013-11-19 17:09:32,269 connection lost: write connection reset: [Errno 32] Broken pipe

So I am a bit stuck here.

For some info on the setup with the SSH it is this:

Local machine (Windows 7 x64) -> gateway-server -> server-host (running a xpra daemon)

I have set this up in Putty as a saved config "ANU" using the local proxy options and plink as documented here:


Can you guys help me?


Leith Bade

leith.bade at anu.edu.au

More information about the shifter-users mailing list