[winswitch] Problem using Xpra client on Windows

Antoine Martin antoine at nagafix.co.uk
Wed Nov 20 14:14:39 GMT 2013

On 19/11/13 13:14, Leith Bade wrote:
> Hi,
> I am trying to get the Windows Xpra client to use a saved SSH proxy chain from PuTTY.
> When I run:
> Xpra_cmd.exe attach -ssh="plink -load ANU"
> I get this:
> xpra client version 0.10.9
> Usage:
>         Xpra_cmd.exe attach [DISPLAY]
>         Xpra_cmd.exe detach [DISPLAY]
>         Xpra_cmd.exe screenshot filename [DISPLAY]
>         Xpra_cmd.exe info [DISPLAY]
>         Xpra_cmd.exe version [DISPLAY]
>         Xpra_cmd.exe shadow DISPLAY
> (This xpra installation does not support starting local servers.)
> Xpra_cmd.exe: error: cannot find a live server to connect to
Just like the error message says: you are not specifying which display
to connect to.
The "--ssh=" switch only specifies the ssh command line to use when
using ssh for transport.
> So I tried again with
> Xpra_cmd.exe attach :100 -ssh="plink -load ANU"
Unless you have a local unix display running on Windows via cygwin, this
command line is just as wrong as the previous one.
(and even if you did, I'm not even sure that would work as cygwin is not
> Then I got:
> xpra client version 0.10.9
> connection failed: 'module' object has no attribute 'AF_UNIX'
I'll try to improve the error message, but this will remain an error.
> So I tried again with:
> Xpra_cmd.exe attach ssh:server-host:100 -ssh="plink -load ANU"
That looks more correct: now you are telling xpra where the server is
*and* that you want an ssh connection to it. (assuming "server-host"
resolves or that you use its IP)
> 2013-11-19 17:09:25,542 GL Extension GL_ARB_vertex_program available
> 2013-11-19 17:09:32,153 write connection reset for TwoFileConnection(ssh:server-host:100)
> 2013-11-19 17:09:32,154 Connection lost
> 2013-11-19 17:09:32,154 connection closed after 0 packets received (0.0 bytes) and 1 packets sent (0.0 bytes)
> 2013-11-19 17:09:32,269 connection lost: write connection reset: [Errno 32] Broken pipe
> So I am a bit stuck here.
Does it work from a Linux client?
Are you sure that your username is indentical on both hosts? (if not,
add username at host or specify it in the plink command line)
> For some info on the setup with the SSH it is this:
> Local machine (Windows 7 x64) -> gateway-server -> server-host (running a xpra daemon)
> I have set this up in Putty as a saved config "ANU" using the local proxy options and plink as documented here:
> http://mikelococo.com/2008/01/multihop-ssh/
> Can you guys help me?
Try connecting to your server with a simple terminal (putty.exe on win32
or a plain terminal on Linux), and if you can connect to the server with
that same command line, then verify that there is an xpra server to
connect to. ("xpra list" should be enough to see it)

> Thanks,
> Leith Bade
> leith.bade at anu.edu.au
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list