[winswitch] xpra wick - how to submit questions

Antoine Martin antoine at devloop.org.uk
Thu Aug 14 06:58:14 BST 2014

>> My guess is that you may have also run winswitch, which automatically
>> manages your xpra sessions and will password protect them for you.
> indeed I had, but it failed to start properly with lots of error
> messages, and I assumed it was not running.  ps showed that winswitch
> was actually running, but not windows showing anywhere. Have killed it
> now;  problem solved.  thanks
I think the amount of logging is not helping here.
It is in fact quite normal to see a number of warnings and errors, as
not all the features are available everywhere.
It probably was working OK, hard to say without the actual message.
> FYI On my linux machine, I went through the Linux install procedure
> at http://winswitch.org/downloads/rpm-repository.html?dist_select=CentOS6
> , including adding rpm fusion.org <http://fusion.org> and EPEL.  No
> error messages from any of the steps, including the last “yum install
> winswitch”.   But attempting to start winswitch produces many error
> messages.  Hence I gave up on winswitch and went with xpra from cmd
> line.  I can post a transcript under bugs or to mail list if you care
> to chase on it.  Not required from my part…cmd line works fine for me.
Problem solved!
> Bummer.  Ok.  But looks like I can run the app on the Mac from the
> command line (for multiple connections) with
> "/Applications/Xpra.app/Contents/MacOS/Xpra…" and exit them via Ctl-C,
> so all is well.
> ________
> Only problem with cmd line seems to be that the script Xpra doesn’t
> get the path right if it’s alias’d or symbolic linked.  
> t tried putting a symbolic link to it in my bin directory, and here’s
> what happens:
> $ ln -s /Applications/Xpra.app/Contents/MacOS/Xpra ~/bin/xpr$ xpra -h
> /Users/iscottfl/bin/xpra: line 78: /Users/Contents/Resources/bin/Xpra:
> No such file or directory
> /Users/iscottfl/bin/xpra: line 78: exec:
> /Users/Contents/Resources/bin/Xpra: cannot execute: No such file or
> directory
> To fix that, you could replace
> exe_name=$(basename $0)
> full_path=$(cd "$(dirname "$0")"; pwd)
> with 
> true_name=$( readlink $0 )
> exe_name=$(  basename $true_name )
> full_path=$( dirname $true_name )
> read link properly resolves symbolic links to the true pathname.  It
> also gets the full pathname if the file is found via the search path. 
That doesn't work when used directly:

cat ./bin/test
true_name=$(readlink $0)
echo true_name=$true_name


Also, it would need quotes to deal with paths that have spaces in them.
> Note:  under other linux’s, like RedHat and Centos, use “read link -f …”
> If you need the script to be portable between linux & os x, you’d
> probably need something along the lines of
> if [[ $OSTYPE == darwin* ]]
> then
> true_name=$( readlink $0 )
> else
> true_name=$( read link -f $0 )
> fi
These scripts are used only on OSX, so we don't need the check.


> cheers.
> Ian Scott-Fleming
> Texas Tech Climate Science Center
> ian.scott-fleming at ttu.edu <mailto:ian.scott-fleming at ttu.edu>

More information about the shifter-users mailing list