[winswitch] Seeing lots of delays with xpra

Antoine Martin antoine at nagafix.co.uk
Tue Dec 2 20:23:43 GMT 2014


On 02/12/14 10:46, Douglas Doole wrote:
> Lately when using xpra, I've been seeing lots of spinners over top of my
> windows. (And I mean "lots" in the sense that xpra is pretty much unusable
> at times.) In the past, xpra was working without these delays.
> When this happens, I see messages like this in the client log:
> 2014-12-02 13:20:53,784 server is not responding, drawing spinners over the
> windows
> 2014-12-02 13:21:05,074 server is OK again
> In the server log, I see messages like this:
> 2014-12-02 13:20:23,261 delayed_region_timeout: region is 15001ms old, bad
> connection?
> 2014-12-02 13:20:28,963 send_delayed for wid 23, elapsed time 5701.0 is
> above limit of 500.0 - sending now
Funny coincidence, a ticket just got created with very similar symptoms:
> Occasionally it is so bad that xpra disconnects. At that point the server
> log will contain:
> 2014-12-02 13:24:08,767 Disconnecting client
> Protocol(SocketConnection(/home/doole/.xpra/reorx-1)): client ping timeout
> (waited 60 seconds without a response)
> 2014-12-02 13:24:08,769 xpra client disconnected.
> Both my xpra server and client are on the same network (but not the same
> subnet). If I use "ssh -X" directly to the box, I do not see any sort of
> delays.
> My windows are mostly konsole and gvim.
> I'd love to be able to say "this problem started with version X", but I
> haven't been able to pin it down. Unfortunately, my environment went though
> multiple changes at the same time (xpra 0.13.x to 0.14.x, Ubuntu 12.04 to
> 14.04), so I may not be able to get back to a good state for comparison
> purposes.
> I am running without speaker/microphone forwarding but everything else
> enabled. I have tried various encoding options, but it doesn't seem to make
> a difference.
> My client and server are both running Ubuntu 14.04. I'm currently running
> xpra 0.14.12 at both the client and server, but I've been seeing this on
> all the xpra 0.14.x builds that I've tried.
> Any suggestions? Anything I can do to help narrow this down further?
Can you please add your info to the ticket and subscribe to it?
If we know how to reproduce it, we should be able to fix it quickly.

> Thanks.

More information about the shifter-users mailing list