[winswitch] xpra unuseable on CentOS 5

Lukas Haase lukashaase at gmx.at
Fri Nov 7 07:14:36 GMT 2014

Unfortunately my problem is difficult to describe.
First of all, I used an old xpra v0.11.2 happily on an Ubuntu machine for over 1 year.
I did not have root rights so I needed to hack around with $PYTHONPATH, manually extracting files from debs to my home directory and finally, this old version was the one worked.
Now I have a machine with CentOS 5.11 and I am facing heavy problems with xpra. I use the winswitch repository and just did "yum install xpra".
When I use xpra is it very slaggish, it sometimes does not react to keystrokes. Also, when there is text input, I cannot place the cursor there (it just does not react).
Or it marks multiple test block in different text fields (which technically can't happen) or the cursor jumps around wildly in different text fields.
Anyway, it's really hard to describe exactly. Sometimes it works at the beginning, then stopes. Sometimes it does not work at all.
It just makes it completely unuseable!
The connection is a GB connection directly to the server (client is Win7 with cygwin), the server is a 2 core virtual machine with 8GB RAM, no load.
This is neither a hardware, nor a network problem.
It is also evident in the sense that I use X forwarding directly with the *same* setup but without xpra, it works flawlessly and perfectly!
I tried setting "--encoding=rgb". This helped a little bit. But not much.
I tried setting "--no-keybard-sync". This did not change anything.
In the terminal I get:
$ xpra attach :1984 --encoding=rgb
2014-11-06 21:08:29,194 xpra client version 0.14.9
2014-11-06 21:08:29,213 OpenGL support could not be enabled:
2014-11-06 21:08:29,213  No module named gdkgl
2014-11-06 21:08:29,219 error running '['setxkbmap', '-print']': [Errno 2] No such file or directory
2014-11-06 21:08:29,351 dbus setup error: No module named mainloop.glib
2014-11-06 21:08:29,356 cannot use mmap: python version is too old?
2014-11-06 21:08:29,364 detected keyboard: rules=base, model=pc105, layout=us
2014-11-06 21:08:29,366 desktop size is 3200x1200 with 1 screen(s):
2014-11-06 21:08:29,367   'localhost:10.0' (847x318 mm)
2014-11-06 21:08:29,367     monitor 1 1920x1200 at 1280x0
2014-11-06 21:08:29,367     monitor 2 1280x768 at 0x193
2014-11-06 21:08:29,371 sound support not available: No module named sound
2014-11-06 21:08:29,398 server: Linux Linux-2.6.18-398.el5-x86_64-with-redhat-5.11-Final, Xpra version 0.14.9 (runknown)
2014-11-06 21:08:29,443 Attached to :1984 (press Control-C to detach)
2014-11-06 21:20:55,061 server is not responding, drawing spinners over the windows
2014-11-06 21:20:55,568 server is OK again
2014-11-06 21:23:10,510 server is not responding, drawing spinners over the windows
2014-11-06 21:23:11,039 server is OK again
The last lines appear over and over again. But as mentioned: No network latency, no load on either server and client!
What bothers me a little bit is "cannot use mmap: python version is too old?".
I have "Python 2.4.3", the standard from CentOS. Is this really too old?
Would anyone be kind to help me to debug this problem and hopefully get xpra working?
I don't want to use VNC (which forwards the whole desktop)... :-(
Thanks so much

More information about the shifter-users mailing list