[winswitch] xpra unuseable on CentOS 5

Antoine Martin antoine at nagafix.co.uk
Fri Nov 7 15:26:42 GMT 2014


On 07/11/14 14:14, Lukas Haase wrote:
> Hi,
> Unfortunately my problem is difficult to describe.
> First of all, I used an old xpra v0.11.2 happily on an Ubuntu machine
for over 1 year.
> I did not have root rights so I needed to hack around with
$PYTHONPATH, manually extracting files from debs to my home directory
and finally, this old version was the one worked.
> Now I have a machine with CentOS 5.11 and I am facing heavy problems
with xpra. I use the winswitch repository and just did "yum install xpra".
> When I use xpra is it very slaggish, it sometimes does not react to
keystrokes. Also, when there is text input, I cannot place the cursor
there (it just does not react).
> Or it marks multiple test block in different text fields (which
technically can't happen) or the cursor jumps around wildly in different
text fields.
> Anyway, it's really hard to describe exactly. Sometimes it works at
the beginning, then stopes. Sometimes it does not work at all.
> It just makes it completely unuseable!
Try the usual suspects: turn off clipboard, opengl, sound, etc..
If the problem persists, it would be worth downgrading the server (try
0.13.x or 0.12.x), to see if it helps.
> The connection is a GB connection directly to the server (client is Win7 with cygwin), the
server is a 2 core virtual machine with 8GB RAM, no load.
You are using the native MS Windows client right? Anything else, like a
cygwin build for example, is not supported and will not work well - if
at all.
> This is neither a hardware, nor a network problem.
> It is also evident in the sense that I use X forwarding directly with
the *same* setup but without xpra, it works flawlessly and perfectly!
With a gigabit connection, you should get near-local performance.
> I tried setting "--encoding=rgb". This helped a little bit. But not much.
> I tried setting "--no-keybard-sync". This did not change anything.
> In the terminal I get:
> $ xpra attach :1984 --encoding=rgb
> 2014-11-06 21:08:29,194 xpra client version 0.14.9
> 2014-11-06 21:08:29,213 OpenGL support could not be enabled:
> 2014-11-06 21:08:29,213  No module named gdkgl
> 2014-11-06 21:08:29,219 error running '['setxkbmap', '-print']':
[Errno 2] No such file or directory
> 2014-11-06 21:08:29,351 dbus setup error: No module named mainloop.glib
> 2014-11-06 21:08:29,356 cannot use mmap: python version is too old?
> 2014-11-06 21:08:29,364 detected keyboard: rules=base, model=pc105,
> 2014-11-06 21:08:29,366 desktop size is 3200x1200 with 1 screen(s):
> 2014-11-06 21:08:29,367   'localhost:10.0' (847x318 mm)
> 2014-11-06 21:08:29,367     monitor 1 1920x1200 at 1280x0
> 2014-11-06 21:08:29,367     monitor 2 1280x768 at 0x193
> 2014-11-06 21:08:29,371 sound support not available: No module named sound
> 2014-11-06 21:08:29,398 server: Linux
Linux-2.6.18-398.el5-x86_64-with-redhat-5.11-Final, Xpra version 0.14.9
> 2014-11-06 21:08:29,443 Attached to :1984 (press Control-C to detach)
> 2014-11-06 21:20:55,061 server is not responding, drawing spinners
over the windows
> 2014-11-06 21:20:55,568 server is OK again
> 2014-11-06 21:23:10,510 server is not responding, drawing spinners
over the windows
> 2014-11-06 21:23:11,039 server is OK again
> The last lines appear over and over again. But as mentioned: No
network latency, no load on either server and client!
> What bothers me a little bit is "cannot use mmap: python version is
too old?".
> I have "Python 2.4.3", the standard from CentOS. Is this really too old?
Very much so. Python 2.4.3 was released in early 2006 and upstream
support has stopped a long time ago.
CentOS 5 is supported in the 0.14 LTS branch only, but barely: it should
run but it is not meant to provide the features or performance found on
more recent OSes, versions 0.15 onwards will not support CentOS 5.x
It is time to move on.
> Would anyone be kind to help me to debug this problem and hopefully get xpra working?
I've just tried my CentOS 5.x test VMs and did not experience any
problems, no slow downs connecting with a Windows 7 client.
There must be something unusual in your setup or the application that
you use.
Please file a ticket with as many details as you can provide and we can
try to get to the bottom of it:
> I don't want to use VNC (which forwards the whole desktop)... :-(
Fair enough!


> Thanks so much

More information about the shifter-users mailing list