[winswitch] Not able to connect to a started xpra

Ronald Sterckx ronald.sterckx at gmail.com
Wed Jun 24 11:14:42 BST 2015


Found it, after putting more logging in noticed the socket name got 
cleared after " #publish mdns records: " in server.py.
So I tried what the log file actually proposed: "2015-06-24 11:42:39,809 
either fix your installation or use the '--no-mdns' flag "

So in the end adding --no-mdns helps on this machine. It's weird that on 
my other machine without avahi this does not occur.  But I have a good 


On 22/06/15 20:57, Antoine Martin wrote:
> On 22/06/15 20:35, Ronald Sterckx wrote:
>>> Does turning daemon on cause the socket errors?
>> Yes, at least turning daemon off makes the socket errors disappear.
> OK, now I understand.
>>> (please include the exact command line used)
>>> I'm confused: your original post stated that you were getting those
>>> socket errors when not using the socket option.
>>> What has changed?
>> Doing "/usr/bin/xpra --socket-dir=/tmp start :10" or "/usr/bin/xpra
>> start :10" produces the same error in the log file.  So socket-dir
>> does not make a difference. (This was your first suggestion)
>>> You didn't answer the question about $HOME being on nfs or something
>>> else.
>>> This would help me reproduce the problem.
>> As far as I know, no.  However the setup of this machine has not been
>> done by me.
> OK, I only asked because the user's home in your log sample is
> "/home/INTRA/ronalds/", which is non-default.
> And there might be other non-default things at play here since I am not
> seeing this problem on a plain Ubuntu Vivid install.
>> I've added some logging on my side. In server_core.py in init_sockets
>> line 235 I added:
>> log("socket name '%s'", sock.getsockname())
>> when I run with "/usr/bin/xpra --daemon=no start :10 -d all" I receive
>> this line in my logs:
>> 2015-06-22 20:27:01,413 socket name '/tmp/hostname-10'
>> When I run in daemon mode with "/usr/bin/xpra start :10 -d all" I get
>> this in my log file
>> 2015-06-22 20:26:36,346 socket name ''
> That's very very odd.
> The daemon code has not changed in a very long time and I don't really
> see how it would end up clearing the socket name.
> I'm really not sure what to suggest next, sorry.
>> I hope I'm being a bit more clear now.
> Perfect, thanks!
> Antoine

More information about the shifter-users mailing list