[winswitch] Mouse stops working

Thomas Mainka thomas.mainka at gmail.com
Sat Jun 4 19:26:29 BST 2016


I am currently trying to track down a strange bug I run into from time
to time: After a while the mouse stops working properly inside any
Xpra windows, so the application becomes unresponsive. The strange
thing though: the keyboard still works, and the mouse works again for
a short time if you use the left Alt key, but stops working once you
use a mouse button once. You can see any mouseover-effects (in like
button bars) in the applications while the mouse works, and its gone
once you click anything.

If the application is having a custom cursor you can also tell the
status of the mouse by the fact that  the custom cursor is displayed:
A non-working mouse cursor displays the standard mouse cursor of the
client OS.

The server is an x86_64 Arch Linux with the 0.17.3 I just compiled.
The client however can be anything: Linux, Windows 10 or OSX - all
have the same problems. Currently my assumption is that this may not
be even a Xpra bug, because the first time I remember it occurring was
after an upgrade to Xorg 1.18.3.

As this looks like a server side problem, I tried to debug the problem
on the server, but "-d all" is pretty talkative. There is a "-d
keyboard" debug level, but no "-d mouse" one.

Any hints on how to track down the underlying problem?


More information about the shifter-users mailing list