[winswitch] Mouse stops working

Antoine Martin antoine at nagafix.co.uk
Sun Jun 5 05:50:55 BST 2016

On 05/06/16 01:26, Thomas Mainka wrote:
> Hi,
> I am currently trying to track down a strange bug I run into from time
> to time: After a while the mouse stops working properly inside any
> Xpra windows, so the application becomes unresponsive. The strange
> thing though: the keyboard still works, and the mouse works again for
> a short time if you use the left Alt key, but stops working once you
> use a mouse button once. You can see any mouseover-effects (in like
> button bars) in the applications while the mouse works, and its gone
> once you click anything.
That's very odd. The server is clearly receiving the mouse position
packets since you get the mouseover effects.
Maybe the event gets delivered to the wrong window and/or the focus ends
up in the wrong place.

> If the application is having a custom cursor you can also tell the
> status of the mouse by the fact that  the custom cursor is displayed:
> A non-working mouse cursor displays the standard mouse cursor of the
> client OS.
> The server is an x86_64 Arch Linux with the 0.17.3 I just compiled.
> The client however can be anything: Linux, Windows 10 or OSX - all
> have the same problems. Currently my assumption is that this may not
> be even a Xpra bug, because the first time I remember it occurring was
> after an upgrade to Xorg 1.18.3.
This would not be the first regression in Xorg 1.18.x stable updates:

> As this looks like a server side problem, I tried to debug the problem
> on the server, but "-d all" is pretty talkative. There is a "-d
> keyboard" debug level, but no "-d mouse" one.
There is a "-d mouse", just tested now and it worked fine here.

> Any hints on how to track down the underlying problem?
I would try to downgrade Xorg to an older version, look at "xpra info |
grep cursor" as you move the mouse. Maybe also look for the "focus" info.
It is worth trying to downgrade xpra to v0.14.x to rule out a
regression. Maybe running "xev" or a simple xterm will help figure
things out.
Failing that, I think you may have to file an xpra bug report.


> Regards,
> Thomas
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list