[winswitch] can't connect with windows 7 client

Thomas Esposito thomase00 at yahoo.com
Sat Oct 1 05:28:20 BST 2016

I'm running an xpra server on a redhat el6.6 remote redhat el 6.6 virtual
machine. I don't have root permissions, so I did the following:

1.) Downloaded the following rpms to my home directory:

2.) For each rpm, I ran:
rpm2cpio PACKAGE.rpm > PACKAGE.cpio
cpio -idv < PACKAGE.cpio

This unpacks the contents of all of the rpms as if my home directory were
e.g. The path to the xpra executable is ${HOME}/usr/bin

3.) Set the following env variables:

At this point, I can start an xpra session:

xpra start :100

After setting DISPLAY=:100, I can start an xterm within the session.

It is important to note that up to this point, I'm running everything on
the RHEL6 server from within a VNC desktop session.

'xpra list' reports that the session is live.

On my local Windows 7 machine, I have downloaded the xpra client. When I
attempt to connect via ssh, after entering the correct login password, I
immediately get a dialog box with the following error:

Server unexpectedly closed network connection.

If I run Xpra_cmd.exe from a command line terminal, I get the following
output when attempting to connect:

Xpra gtk2 client version 0.17.5-r13487
 running on Microsoft Windows 7
GStreamer version 1.8 for Python 3.4
OpenGL_accelerate module loaded
 detected keyboard: layout=us
 desktop size is 1920x1080 with 1 screen:
   Default (508x285 mm - DPI: 96x96) workarea: 1920x1040
        DISPLAY1 (677x381 mm - DPI: 72x72)
failed to receive anything, not an xpra server?
  could also be the wrong username, password or port
  or maybe this server does not support 'unknown' compression or 'bencode'
packet encoding?

I know it's not the wrong username or password, because if either is
incorrect, I don't even get that far. The part about 'unknown' compression
is curious because I have H.264 encoding selected in the client.

Back on my VNC desktop on the server, I can attach with:

xpra attach :100

and the xpra client starts, connects, and the xterm appears on my VNC

So the session DEFINITELY exists, and I am just having a problem connecting
to the remote session from my local Windows machine.

Here is the contents of the ${HOME}/.xpra/:100.log file after starting up
the session:

X.Org X Server 1.15.0
Release Date: 2013-12-27
X Protocol Version 11, Revision 0
Build Operating System: x86-027 2.6.18-400.1.1.el5
Current Operating System: Linux sjlvda1566 2.6.32-504.30.3.el6.x86_64 #1
SMP Thu Jul 9 15:20:47 EDT 2015 x86_64
Kernel command line: ro root=UUID=8230e56b-29bb-498d-861a-920ce03d479f
rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16
crashkernel=129M at 0M  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
Build Date: 06 February 2015  12:21:48AM
Build ID: xorg-x11-server 1.15.0-26.el6_6
Current version of pixman: 0.32.4
Before reporting problems, check https://www.redhat.com/apps/support/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/home/thomase/.xpra/Xorg.:100.log", Time: Sat Oct  1
00:21:11 2016
(++) Using config file: "/home/thomase/.xpra/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
2016-10-01 00:21:11,711 created unix domain socket:
/home/thomase/.xpra/sjlvda1566-100 [0m
DeprecationWarning: object.__init__() takes no parameters
  super(Connection, self).__init__(*args, **kwargs)
[33m2016-10-01 00:21:12,120 Warning: using fallback encryption library
pycrypto [0m
[33m2016-10-01 00:21:12,121  python-cryptography is not available: No
module named cryptography [0m
[33m2016-10-01 00:21:13,250 Warning: webcam forwarding is disabled [0m
[33m2016-10-01 00:21:13,250  the virtual video directory
'/sys/devices/virtual/video4linux' was not found [0m
[33m2016-10-01 00:21:13,250  make sure that the 'v4l2loopback' kernel
module is installed and loaded [0m
2016-10-01 00:21:13,250 found 0 virtual video devices [0m
2016-10-01 00:21:13,283 pulseaudio server started with pid 23074 [0m
E: pid.c: Daemon already running.
2016-10-01 00:21:13,842 GStreamer version 0.10 for Python 2.6 [0m
2016-10-01 00:21:13,895 D-Bus notification forwarding is available [0m
2016-10-01 00:21:13,925 xpra X11 version 0.17.5-r13455 [0m
2016-10-01 00:21:13,991  running with pid 23039 on Linux Red Hat Enterprise
Linux Server 6.6 Santiago [0m
2016-10-01 00:21:13,991  on display :100 [0m
2016-10-01 00:21:14,010 xpra is ready. [0m
[33m2016-10-01 00:21:16,134 Warning: lpinfo command failed and returned 1
[33m2016-10-01 00:21:16,135  command used: '/usr/sbin/lpinfo
--make-and-model Generic PDF Printer -m' [0m
[33m2016-10-01 00:21:16,224 Warning: pulseaudio has terminated shortly
after startup. [0m
[33m2016-10-01 00:21:16,224  pulseaudio is limited to a single instance per
user account, [0m
[33m2016-10-01 00:21:16,224  and one may be running already for user
'thomase' [0m
[33m2016-10-01 00:21:16,224  to avoid this warning, either fix the
pulseaudio command line [0m
[33m2016-10-01 00:21:16,224  or use the 'pulseaudio=no' option [0m

Nothing gets added to this log file when I make the failed connection
attempt from my Windows machine.

Any ideas what might be the problem?

More information about the shifter-users mailing list