[winswitch] can't connect with windows 7 client

Antoine Martin antoine at nagafix.co.uk
Sat Oct 1 06:34:12 BST 2016

On 01/10/16 11:28, Thomas Esposito via shifter-users wrote:
> I'm running an xpra server on a redhat el6.6 remote redhat el 6.6 virtual
> machine. I don't have root permissions, so I did the following:
> 1.) Downloaded the following rpms to my home directory:
> 2.) For each rpm, I ran:
> rpm2cpio PACKAGE.rpm > PACKAGE.cpio
> cpio -idv < PACKAGE.cpio
> This unpacks the contents of all of the rpms as if my home directory were
> '/'.
> e.g. The path to the xpra executable is ${HOME}/usr/bin
> 3.) Set the following env variables:
> PYTHONPATH=$PYTHONPATH:${HOME}/usr/lib64/python2.6/site-packages
> PATH=$PATH:${HOME}/usr/bin
> LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${HOME}/usr/lib64:${HOME}/usr/lib64/gstreamer-0.10:/${HOME}/usr/lib64/xorg/modules/drivers:${HOME}/usr/lib64/xpra
Does Xorg honour the module path for loading the dummy driver this way?
(check for "dummy" warnings in your Xorg log file)

> At this point, I can start an xpra session:
> xpra start :100
> After setting DISPLAY=:100, I can start an xterm within the session.
FYI: always prefer this form:
xpra start :100 --start=xterm
As this will set the environment correctly for the application launched.
(and also detach it from the terminal you run from)

> It is important to note that up to this point, I'm running everything on
> the RHEL6 server from within a VNC desktop session.
> 'xpra list' reports that the session is live.
> On my local Windows 7 machine, I have downloaded the xpra client. When I
> attempt to connect via ssh, after entering the correct login password, I
> immediately get a dialog box with the following error:
> Server unexpectedly closed network connection.
> If I run Xpra_cmd.exe from a command line terminal, I get the following
> output when attempting to connect:
Please always provide the exact command line that you used (minus any
passwords and IP addresses, etc), ie:
Xpra_cmd attach ssh/username:password at host:22/100

> Xpra gtk2 client version 0.17.5-r13487
>  running on Microsoft Windows 7
> GStreamer version 1.8 for Python 3.4
> OpenGL_accelerate module loaded
>  detected keyboard: layout=us
>  desktop size is 1920x1080 with 1 screen:
>    Default (508x285 mm - DPI: 96x96) workarea: 1920x1040
>         DISPLAY1 (677x381 mm - DPI: 72x72)
> failed to receive anything, not an xpra server?
>   could also be the wrong username, password or port
>   or maybe this server does not support 'unknown' compression or 'bencode'
> packet encoding?
> I know it's not the wrong username or password, because if either is
> incorrect, I don't even get that far. The part about 'unknown' compression
> is curious because I have H.264 encoding selected in the client.
That's the packet compression and encoding, not picture encoding.
It means that no packets were exchanged with the server.

> Back on my VNC desktop on the server, I can attach with:
> xpra attach :100
> and the xpra client starts, connects, and the xterm appears on my VNC
> desktop.
> So the session DEFINITELY exists, and I am just having a problem connecting
> to the remote session from my local Windows machine.
> Here is the contents of the ${HOME}/.xpra/:100.log file after starting up
> the session:
> Nothing gets added to this log file when I make the failed connection
> attempt from my Windows machine.
> Any ideas what might be the problem?
The run-xpra script which is executed via ssh may not be able to
correctly setup the environment and therefore fails to connect to your
xpra server instance. Try running from your server:
~/.xpra/run-xpra list :100
~/.xpra/run-xpra info :100

Also try to connect via ssh from Linux to rule out any problems with the
client side.


More information about the shifter-users mailing list