[winswitch] can't connect with windows 7 client

Antoine Martin antoine at nagafix.co.uk
Sun Oct 2 11:19:19 BST 2016

>     > Server unexpectedly closed network connection.
>     >
>     > If I run Xpra_cmd.exe from a command line terminal, I get the following
>     > output when attempting to connect:
>     Please always provide the exact command line that you used (minus any
>     passwords and IP addresses, etc), ie:
>     Xpra_cmd attach ssh/username:password at host:22/100
> For the Windows client, I am literally just running that command (i.e.
> no args), and then starting up the session with the GUI. 
You should always try the command line version when reporting bugs, as
it can be easily cut&pasted and it is much easier to spot obvious problems.
>     > Any ideas what might be the problem?
>     The run-xpra script which is executed via ssh may not be able to
>     correctly setup the environment and therefore fails to connect to your
>     xpra server instance. Try running from your server:
>     ~/.xpra/run-xpra list :100
>     or:
>     ~/.xpra/run-xpra info :100
> If I go to a different terminal on the same machine (i.e. where I
> started the server) WITHOUT the environment variables set up as I have
> described above, I can start a session, run an xterm on it, and attach
> to the session successfully as follows:
> ~/.xpra/run-xpra start :100
> xterm -display :100 &
> ~/xpra/run-xpra attach :100  
>     Also try to connect via ssh from Linux to rule out any problems with the
>     client side.
> I CANNOT attach via ssh from another Linux machine. After successfully
> entering my ssh password, I get the following error message:
> 2016-10-01 09:33:37,037 The SSH process has terminated with exit code 255
> 2016-10-01 09:33:37,037  the command line used was:
> 2016-10-01 09:33:37,037  ssh -x -T */server_name/* xpra
> initenv;~/.xpra/run-xpra _proxy :100 || $XDG_RUNTIME_DIR/xpra/run-xpra
> _proxy :100 || xpra _proxy :100 
Try running just this command from a Linux terminal:
ssh -x -T $SERVERHOST ~/.xpra/run-xpra _proxy :100
Then press enter a few times, this should connect your terminal to the
remote xpra server. The server will be confused by your keyboard input
and print something like:
disconnect: invalid packet header, character 0xa, not an xpra client??

Maybe your ssh shell commands are restricted, or it uses a non-standard
shell which is incompatible with the proxy syntax we use.

> At this point, after seeing the 'xpra initenv' command here, I thought
> that I was on to something, so I added the PATH, PYTHONPATH, and
> LD_LIBRARY_PATH setup as described above to my ~/.bashrc. Unfortunately,
> after doing this, I still get the same error when attempting to connect
> from another Linux machine (and my Windows machine).
xpra initenv is there to setup one of the "run-xpra" scripts on the
system if one is not present yet.
You can override it using the environment variable XPRA_INITENV_COMMAND.
ie to disable it:
XPRA_INITENV_COMMAND="" xpra attach ssh ...


More information about the shifter-users mailing list