[winswitch] HTML start-desktop crash

Antoine Martin antoine at nagafix.co.uk
Mon Feb 13 11:27:42 GMT 2017

On 13/02/17 18:19, Berdonces Bonelo, Erik via shifter-users wrote:
> Hello,
> As a small update, I’ve been trying with different versions of xPra, and seems that all the 1.X versions do not work with Ubuntu 14.04 LTS.
All the 1.x versions have been tested with Ubuntu 14.04, including 1.0.3
which was released today.

"do not work" is not specific enough, please see:


> The latest version compatible with ubuntu 14.04 is 0.15.10-1 of Xpra.
> Best regards,
> Erik Berdonces
> On Feb 13, 2017, at 10:51 AM, Berdonces Bonelo, Erik <erik.berdoncesbonelo at tu-berlin.de<mailto:erik.berdoncesbonelo at tu-berlin.de>> wrote:
> Hi,
> I’m sending it back to this mail, because seems I got a migration in my inbox and I didn’t receive the answer back (no worries, I read it in the online mailman archive), plus I got a new mail address.
> On the desktop size the answers helped a lot, and now I’ve been able to run it in Ubuntu 16.04 after uninstalling VirtualBox additions and configuring my screen size.
> However, I’ve tried to repeat the same process in Ubuntu 14.04, installing the latest version from WinSwitch repository and I’m having some troubles. As it seems it can’t create the socket, even if the .xpra folder gets set a 777 chmod and ubuntu is part of the Xpra group of users.
> Errors are as it follows:
> ubuntu at machine86ec8863-384b-4baf-af76-aadfbefd4400:~$ xpra start --bind-tcp= --html=on --no-daemon
> Initializing built-in extension Generic Event Extension
> Initializing built-in extension SHAPE
> Initializing built-in extension MIT-SHM
> Initializing built-in extension XInputExtension
> Initializing built-in extension XTEST
> Initializing built-in extension BIG-REQUESTS
> Initializing built-in extension SYNC
> Initializing built-in extension XKEYBOARD
> Initializing built-in extension XC-MISC
> Initializing built-in extension SECURITY
> Initializing built-in extension XINERAMA
> Initializing built-in extension XFIXES
> Initializing built-in extension RENDER
> Initializing built-in extension RANDR
> Initializing built-in extension COMPOSITE
> Initializing built-in extension DAMAGE
> Initializing built-in extension MIT-SCREEN-SAVER
> Initializing built-in extension DOUBLE-BUFFER
> Initializing built-in extension RECORD
> Initializing built-in extension DPMS
> Initializing built-in extension Present
> Initializing built-in extension DRI3
> Initializing built-in extension X-Resource
> Initializing built-in extension XVideo
> Initializing built-in extension XVideo-MotionCompensation
> Initializing built-in extension SELinux
> Initializing built-in extension GLX
> [dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
> [dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!
> Using display number provided by Xvfb: :0
> Xlib:  extension "RANDR" missing on display ":0".
> Xlib:  extension "RANDR" missing on display ":0".
> 2017-02-13 09:46:02,017 Error: failed to create socket '/home/ubuntu/.xpra/machine86ec8863-384b-4baf-af76-aadfbefd4400-0':
> 2017-02-13 09:46:02,017  [Errno 1] Operation not permitted: '/home/ubuntu/.xpra/machine86ec8863-384b-4baf-af76-aadfbefd4400-0'
> xpra initialization error:
>  failed to create socket /home/ubuntu/.xpra/machine86ec8863-384b-4baf-af76-aadfbefd4400-0
> 2017-02-13 09:46:02,018 closing TCP socket
> 2017-02-13 09:46:02,018 killing xvfb with pid 5842
> ubuntu at machine86ec8863-384b-4baf-af76-aadfbefd4400:~$ umask
> 0002
> This is in a plain Ubuntu Server 14.04 and installing the latest version of xPra and with default configuration. I can run the command with sudo, but then,  it complains that it misses the dbus, websockify and many other packages. If I try to install them by hand, it says they are already installed. So, I’m not sure what’s happening that xPra can’t detect the dependencies are already installed..
> These two things were the ones crashing xPra previously as I see (now running in non-daemon mode seems to keep it running, but still can’t run it in HTML mode and I get lots of warnings)
> Thanks!
> Best regards,
> Erik Berdonces Bonelo
> On Feb 8, 2017, at 5:42 PM, Berdonces Bonelo, Erik <erik.berdoncesbonelo at tu-berlin.de<mailto:erik.berdoncesbonelo at tu-berlin.de>> wrote:
> Hello,
> I’m trying to run a full desktop (I have tried KDE and Unity so far), in order to manage remotely a server.
> At the moment I have this running as a VM in VirtualBox  + VBox Addons in my computer (I hope it isn’t this interfering somehow…). I’ve been trying with Ubuntu 14.04, Ubuntu 16.04, Kubuntu 16.04 and CentOS 7. In all of them I’ve installed the latest release from the Winswitch repository (at the moment 1.0.2).
> Anyways, whenever I start an xpra session,  either if I start it from the client or HTML5 client, the transmitted desktop is a window that is much larger than my actual physical screen, and I can’t even resize it down. I’ve tried with the –desktop-scaling option, but it has no effect.
> Also, I’ve tried to use different desktops (kde, gnome and unity), and to disconnect my physical second screen from my laptop. If I start a simple program as xterm, there are no problems, it’s the proper size. However, doing so with a desktop, it just won’t work.
> Any suggestions on this? I’ve gone through all the xpra manual, but I might have overlooked a setting. Otherwise I don’t know if it can be a bug maybe…
> Thanks a lot, and of course, thanks a lot for your great work and for this tool!
> Best regards,
> Erik berdonces
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list