[winswitch] HTML start-desktop crash

Berdonces Bonelo, Erik erik.berdoncesbonelo at tu-berlin.de
Mon Feb 13 12:44:44 GMT 2017

Hi  again,

I’m sorry but I’m not receiving any of your mails in my mailbox. I have to go to the ML archives an read the answers there.

When I meant it doesn’t work is that it throws exactly the same error. And I’m not using any funny or strange configuration. It’s just a plain Ubuntu 14.04 server installed with default configuration, just install everything, enable SSH, and install xPra using the remote winswitch repo. 0.15.10-1 works as expected, but any version after this, throws the errors that I sent in the previous message.

So procedure to reproduce:

1. Install Ubuntu Server x64 14.04 in VirtualBox (running in MacOS) or any server (I have already tried in both). Simple settings, just enabling SSH server to remote connect and no interface or anything needed. If you want you can install SSH manually later on yourself, but this doesn’t affect the result. No NFS, nothing strange, just a plain installation of ubuntu.

2. Update the packages and install xTerm:`sudo apt-get update && apt-get upgrade -y && apt-get install xterm`

3. Install xPra (via winswitch or deb packages):
3.1Follow the instructions in https://winswitch.org/downloads/debian-repository.html?dist_select=trusty for trusty (14.04).
3.2 I also tried the alternative alternative installing with the deb packages manually from http://xpra.org/dists/trusty/main/binary-amd64/ with dpkg and apt-get install -f (both procedures 3.1 and 3.2 result in the same error later on). I made sure to install websockify, python-xxhash, python-reencode, ffmpeg-xpra when installing deb packages manually. Usually I use the winswitch PPA repo as it’s much easier.

Xpra gets installed with version 1.0.3:

sturgelose at gilgamesh:~$ xpra --version
xpra v1.0.3-r15051

4. Add user ubuntu to Xpra group `sudo usermod -a -G Xpra ubuntu` to avoid problems.

5. Execute `xpra start --bind-tcp= --start-child=xterm` (just start a screen with xterm). There is nothing running in port 14500. You can also try with different ports, and will result the same problems. Also tried with `--html=on` option with the HTML5 client, it will happen exactly the same. And I tried different computers as clients.

If the command in 5. is ran as default non root user (ubuntu user), which is part of the Xpra group (added in 4.), the server doesn’t start and the daemon ends (mostly the error I sent in previous messages):
2017-02-13 09:46:02,017 Error: failed to create socket '/home/ubuntu/.xpra/machine86ec8863-384b-4baf-af76-aadfbefd4400-0':
2017-02-13 09:46:02,017  [Errno 1] Operation not permitted: '/home/ubuntu/.xpra/machine86ec8863-384b-4baf-af76-aadfbefd4400-0'
xpra initialization error:
 failed to create socket /home/ubuntu/.xpra/machine86ec8863-384b-4baf-af76-aadfbefd4400-0

If run the command (5.) as root user (something I’d like to avoid doing), the socket connects, but then when connecting from the client, it says it can’t find bus package (and other packages), which is installed… still you can try to connect a client but the dbus error will kill the process.

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension GLX
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!
Using display number provided by Xvfb: :1
Xlib:  extension "RANDR" missing on display ":1".
Xlib:  extension "RANDR" missing on display ":1".
/home/sturgelose/.xpra/gilgamesh-1 is not responding, waiting for it to timeout before clearing it.....
2017-02-13 13:10:02,461 created unix domain socket: /home/sturgelose/.xpra/gilgamesh-1
2017-02-13 13:10:02,462 Warning: failed to create socket directory '/var/run/xpra'
2017-02-13 13:10:02,463  [Errno 13] Permission denied: '/var/run/xpra'
2017-02-13 13:10:02,463 Warning: cannot create socket '/var/run/xpra/gilgamesh-1'
2017-02-13 13:10:02,464  [Errno 2] No such file or directory
2017-02-13 13:10:02,465  /var/run/xpra does not exist
2017-02-13 13:10:02,465  user 'sturgelose' is a member of groups: adm, cdrom, sudo, dip, plugdev, lpadmin, sambashare, xpra
2017-02-13 13:10:02,551 Warning: menu forwarding is disabled:
2017-02-13 13:10:02,552  cannot load dbus helper: No module named dbus
2017-02-13 13:10:02,932 Warning: libvpx ABI version 5 is too old:
2017-02-13 13:10:02,932  disabling YUV444P support with VP9
2017-02-13 13:10:03,028 Warning: failed to load the mdns avahi publisher:
2017-02-13 13:10:03,029  No module named avahi
2017-02-13 13:10:03,029  either fix your installation or use the 'mdns=no' option
2017-02-13 13:10:03,035 Warning: no X11 RandR support on :1
2017-02-13 13:10:03,953 Error: cannot import websockify connection handler:
2017-02-13 13:10:03,953  cannot import name WebSocketRequestHandler
2017-02-13 13:10:03,954  the html server will not be available
2017-02-13 13:10:04,036 Error: failed to import the virtual video module:
2017-02-13 13:10:04,037  No module named _dbus_bindings
2017-02-13 13:10:04,051 pulseaudio server started with pid 1349
Warning: failed to import GStreamer:
 GStreamer 1.0: Namespace Gst not available
 GStreamer 0.10: No module named pygst
2017-02-13 13:10:04,496 Error: failed to query sound subsystem:
2017-02-13 13:10:04,497  query did not return any data
2017-02-13 13:10:04,499 Warning: failed to load or register our dbus notifications forwarder:
2017-02-13 13:10:04,499  No module named dbus.service
2017-02-13 13:10:04,499  if you do not have a dedicated dbus session for this xpra instance,
2017-02-13 13:10:04,500  use the 'notifications=no' option
2017-02-13 13:10:04,501 Warning: cannot load dbus helper:
2017-02-13 13:10:04,502  No module named dbus
2017-02-13 13:10:04,510 Warning: cannot load dbus server:
2017-02-13 13:10:04,511  No module named dbus
2017-02-13 13:10:04,517 started command 'xterm' with pid 1370
2017-02-13 13:10:04,518 xpra X11 version 1.0.3-r15051 64-bit
2017-02-13 13:10:04,519  uid=1000 (sturgelose), gid=1000 (sturgelose)
2017-02-13 13:10:04,519  running with pid 1298 on Linux Ubuntu 14.04 trusty
2017-02-13 13:10:04,520  connected to X11 display :1
2017-02-13 13:10:04,632 xpra is ready.
2017-02-13 13:10:04,635 2.0GB of system memory
2017-02-13 13:10:11,299 New tcp connection received from
2017-02-13 13:10:11,302 Warning: client expects a challenge but this connection is unauthenticated
2017-02-13 13:10:11,319 Handshake complete; enabling connection
2017-02-13 13:10:11,424 Warning: xxhash python bindings not found
2017-02-13 13:10:11,425  no scrolling detection
2017-02-13 13:10:11,438 server error processing new connection from Protocol(tcp socket: <- No module named dbus
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/server/server_core.py", line 893, in _process_hello
    self.hello_oked(proto, packet, c, auth_caps)
  File "/usr/lib/python2.7/dist-packages/xpra/server/server_base.py", line 1115, in hello_oked
    self.default_speed, self.default_min_speed)
  File "/usr/lib/python2.7/dist-packages/xpra/server/source.py", line 357, in __init__
    self.dbus_server = dbus_exception_wrap(make_dbus_server, "setting up client dbus instance")
  File "/usr/lib/python2.7/dist-packages/xpra/server/dbus/dbus_common.py", line 12, in dbus_exception_wrap
    v = fn()
  File "/usr/lib/python2.7/dist-packages/xpra/server/source.py", line 355, in make_dbus_server
    from xpra.server.dbus.dbus_source import DBUS_Source
  File "/usr/lib/python2.7/dist-packages/xpra/server/dbus/dbus_source.py", line 7, in <module>
    from xpra.dbus.helper import dbus_to_native
  File "/usr/lib/python2.7/dist-packages/xpra/dbus/helper.py", line 7, in <module>
    import dbus
ImportError: No module named dbus
2017-02-13 13:10:11,444 Disconnecting client
2017-02-13 13:10:11,445  server error (error accepting new connection)

This happens with any xPra 1.X version. I tried downgrading Xpra to 0.15.10 with Ubuntu 14.04 and works like a charm. Also, try the whole same procedure in Ubuntu 16.04 and it works as expected (no errors nor warnings).

In the client I only have one screen (disconnected the second one and  rebooted even). I tried with other computers as clients and it’s just the same. The problem is in the xPra server.

I attach as well an export of the server configuration done with xPra.

More information about the shifter-users mailing list