[winswitch] Xpra - Docker - Assistance request

Timothy Hobbs timothy at hobbs.cz
Sun Jan 8 10:15:54 GMT 2017


I'm the author of a project called subuser.org which helps users install 
and use GUI applications in Docker. We use XPRA, but we don't do CRIU 
and don't plan on it either.

In my experience, there using XPRA with containers isn't bad practice, 
I'm not sure where you heard that from. It works quite well actually.

In order to securely provide access to the X11 server, I have subuser 
set up to use a 3 container per application approach which is described 
here http://subuser.org/news/0.3.html#the-xpra-x11-bridge .

I presume you currently have it set up so that the XPRA server runs in 
the same container as the GUI application? Is your trouble then that the 
UNIX sockets INSIDE the container don't work? Aka the applications 
connection to the xpra server via the /tmp/.X11-unix socket?

Or is the trouble with the socket that connects the xpra server to the 
xpra client? If you're running into the former case then I think you 
have no hope of using CRIU for anything usefull untill such a severe bug 
is fixed :(. If it is the later, then I think we might be able to find 
some workarounds, such as detaching the xpra client before freezing and 
then reattaching it afterwards.

On 01/08/2017 01:53 AM, Ali Sadat via shifter-users wrote:
> Hi,
> I appreciate if you could assist me with the following question regarding
> use of xpra inside Docker containers.
> As a part of one of my projects, I have to use xpra inside runc\docker
> containers to access GUI apps. (I understand this is not the best practice)
> Xpra works perfectly inside containers, until I have to checkpoint and
> restore the container. It seems CRIU does not like the concept of
> unix-sockets inside containers and requires special IPC to be created
> between processes. I tried to follow the instructions provided by CRIU for
> VNC in link below. However, could not get xpra to work.
> https://criu.org/VNC
> Tried other approaches too eg: SSH, TCP and... to avoid use of Display
> sockets, but there was not much success there either.
> I am really stuck !!! and I am just wondering if you can help me with this
> or point me toward the right direction.
> Is there any way to create an IPC been xpra and application inside
> container ? or exit xpra session before checkpoint and reconnect to exit-ed
> session after restore ? or...
> Thanks
> Ali
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list