[winswitch] Windows Client: preexec_fn not supported on Windows platform

Thomas Mainka thomas.mainka at gmail.com
Mon Jul 31 19:14:46 BST 2017

The latest version I tried is Windows 64bit v2.1 revision 16505
"built on Win7ProDev-PC by Win7ProDev 2017-07-25 22:26."
That was the .exe Installer directly from the homepage.

I did not use a command line, as the error message pops up in the Xpra
launcher GUI after selecting SSH as connection method.


On Sun, Jul 30, 2017 at 12:09 PM, Antoine Martin via shifter-users
<shifter-users at lists.devloop.org.uk> wrote:
> On 30/07/17 17:06, Thomas Mainka via shifter-users wrote:
>> Hi,
>> I've tried to update my Xpra windows client on Win 10 from 2.0.2, but
>> somehow any newer version since that gives the error message
>> "preexec_fn not supported on Windows platforms".
>> Could this be a problem with a second Python runtime installed somewhere else?
> It could be, or it could also just be a bug.
> Please specify the exact download that you've used (exe? msi? 32-bit?
> 64-bit?) and the exact command line that you've used.
> Please note that the 2.0.x branch is out of date, try using 2.1
> Cheers
> Antoine
>> Regards,
>> Thomas
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list