[winswitch] Unable to attach from Windows

Antoine Martin antoine at nagafix.co.uk
Mon Aug 6 14:24:56 BST 2018

On 06/08/18 14:46, Daniele Polencic via shifter-users wrote:
> Hello,
> I installed Xpra on a Linux VM.
> From my mac I can SSH into the VM with:
> ssh workspace
> and I can attach to an Xpra session with:
> xpra attach ssh:workspace
> I tried to do the same on Windows. I can connect to SSH with:
> ssh workspace
Is this openssh? from mingw? cygwin?

> But I can't connect to Xpra. To attach to an existing session I used:
> "C:\Program Files\Xpra\Xpra_cmd.exe" attach ssh/workspace
> 2018-08-06 13:35:43,593 Error: failed to receive anything, not an xpra
> server?
> 2018-08-06 13:35:43,593   could also be the wrong protocol, username,
> password or port
> 2018-08-06 13:35:43,609   or maybe this server does not support 'unknown'
> compression or 'rencode' packet encoding?
> 2018-08-06 13:35:43,609 Connection lost
> I tried with the UI and it silently fails. I installed the following
> binary: https://xpra.org/dists/windows/Xpra-x86_64_Setup.exe
> The Xpra client on Windows is: v1.0 14492
That's way too old. (over a year and a half's worth of fixes)

> The Xpra client on Mac is: xpra v1.0.12-r19800
Try the latest stable 2.3.x builds for both macos and windows.
There is absolutely no reason to use the 1.x branch on MacOS or MS
Windows unless you run Windows XP or MacOS versions older than 10.9

> The Xpra server running on Ubuntu is: xpra v2.3.2-r19729
> Is there anything else I should try?
Does your system log on the server show a connection attempt at all?
If so, does the ssh authentication succeed?

Try to specify your username and maybe even the password on the command
xpra_cmd attach ssh://username:password@host/

You can also enable ssh debugging with:
This will log the exact SSH command line used for connecting to the
server. You can then run it by hand to see what happens.

The latest 2.4 beta builds I posted yesterday include a new ssh backend
which may give you more diagnostics:
xpra_cmd attach ssh://username:password@host/ -d ssh
You can download 2.4 beta builds from:


> Thanks,
> D
> _______________________________________________
> shifter-users mailing list
> shifter-users at lists.devloop.org.uk
> http://lists.devloop.org.uk/mailman/listinfo/shifter-users

More information about the shifter-users mailing list