[winswitch] Unable to attach from Windows

Daniele Polencic daniele.polencic at gmail.com
Mon Aug 6 13:46:05 BST 2018


I installed Xpra on a Linux VM.

>From my mac I can SSH into the VM with:

ssh workspace

and I can attach to an Xpra session with:

xpra attach ssh:workspace

I tried to do the same on Windows. I can connect to SSH with:

ssh workspace

But I can't connect to Xpra. To attach to an existing session I used:

"C:\Program Files\Xpra\Xpra_cmd.exe" attach ssh/workspace

I also tried to force a display with:

"C:\Program Files\Xpra\Xpra_cmd.exe" attach ssh/workspace/1

The output is the following:

λ "C:\Program Files\Xpra\Xpra_cmd.exe" attach ssh/workspace
2018-08-06 13:35:30,765 Xpra gtk2 client version 2.3.2-r19729 64-bit
2018-08-06 13:35:30,780  running on Microsoft Windows 10
2018-08-06 13:35:38,670 Warning: failed to import opencv:
2018-08-06 13:35:38,670  DLL load failed: A dynamic link library (DLL)
initialization routine failed.
2018-08-06 13:35:38,670  webcam forwarding is disabled
2018-08-06 13:35:39,154 GStreamer version 1.14.1 for Python 2.7.15 64-bit
2018-08-06 13:35:40,381 OpenGL_accelerate module loaded
2018-08-06 13:35:40,475 Using accelerated ArrayDatatype
2018-08-06 13:35:40,979 Warning: vendor 'Parallels and Intel Inc.' is
2018-08-06 13:35:40,979  you may want to turn off OpenGL if you encounter
2018-08-06 13:35:41,111 OpenGL enabled with Parallels using Intel(R) HD
Graphics 530
2018-08-06 13:35:41,173  desktop size is 1024x768 with 1 screen:
2018-08-06 13:35:41,173   Default (270x203 mm - DPI: 96x96) workarea:
2018-08-06 13:35:41,189     DISPLAY1 (200x150 mm - DPI: 130x130)
2018-08-06 13:35:41,236  keyboard settings: layout=us
2018-08-06 13:35:43,593 Error: failed to receive anything, not an xpra
2018-08-06 13:35:43,593   could also be the wrong protocol, username,
password or port
2018-08-06 13:35:43,609   or maybe this server does not support 'unknown'
compression or 'rencode' packet encoding?
2018-08-06 13:35:43,609 Connection lost

I tried with the UI and it silently fails. I installed the following
binary: https://xpra.org/dists/windows/Xpra-x86_64_Setup.exe

The Xpra client on Windows is: v1.0 14492
The Xpra client on Mac is: xpra v1.0.12-r19800
The Xpra server running on Ubuntu is: xpra v2.3.2-r19729

Is there anything else I should try?


More information about the shifter-users mailing list